Modding Help Buttoning up an edit done in Tiled?

Discussion in 'Mods' started by cankersaur, Mar 1, 2019.

  1. cankersaur

    cankersaur Big Damn Hero

    Hello! I'm having trouble getting an edit done in Tiled. I added a custom tilesheet and am not sure where to put that when putting things back together to zip it back up and test it in my game.

    I added a tilesheet called zGamecorner.png, and used it to add a Team Rocket Game Corner beneath the Saloon in Tiled. I want to add it to my game so I can test my warp tiles, but I'm unable to get it to load just replacing the Saloon file, as the zGamecorner tilesheet can't be found.

    • Where do I put zGamecorner?
    • What file format should it be in? Just .png?
    (For the record, I plan on eventually trying to make it CP-compatible so I don't have to dig around in the game files, but I haven't gotten that far yet.)
     

      Attached Files:

      HopeWasHere likes this.
    • Moragaine

      Moragaine Existential Complex

      Custom tilesheets go in the same folder as the .tbin when loading the mod with CP. The game will detect the tilesheet and load it when it loads the map.
       
      • Moragaine

        Moragaine Existential Complex

        @cankersaur Not sure how you're coming on your edits, but I poked at your file a bit more and I now have a version that loads(still seems to need a warp, tho):
         

          Attached Files:

        • cankersaur

          cankersaur Big Damn Hero

          Oh wow! You're definitely ahead of me. Thank you so much! I'll muck around with it some more and try to figure out what I'm doing wrong with the warps.

          Edit: hmm, I can't get the game to start with it added.

          I get this:

          [game] System.IndexOutOfRangeException: Index was outside the bounds of the arra
          y.
          at StardewValley.GameLocation.updateWarps() in C:\Users\gitlab-runner\gitlab-
          runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Locations\GameL
          ocation.cs:line 9390
          at StardewValley.GameLocation.loadObjects() in C:\Users\gitlab-runner\gitlab-
          runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Locations\GameL
          ocation.cs:line 9409
          at StardewValley.GameLocation..ctor(String mapPath, String name) in C:\Users\
          gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\F
          armer\Locations\GameLocation.cs:line 703
          at loadForNewGame_Patch2(Boolean loadedGame)
          at StardewValley.SaveGame.<>c.<getLoadEnumerator>b__56_1() in C:\Users\gitlab
          -runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\
          SaveGame.cs:line 1146
          at System.Threading.Tasks.Task.InnerInvoke()
          at System.Threading.Tasks.Task.Execute()
          [SMAPI] An error occured in the overridden update loop: System.IndexOutOfRangeEx
          ception: Index was outside the bounds of the array.
          at StardewValley.SaveGame.<getLoadEnumerator>d__56.MoveNext() in C:\Users\git
          lab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farm
          er\SaveGame.cs:line 1159
          at Update_Patch1(Object gameTime, GameTime )
           
            Last edited: Mar 2, 2019
          • Moragaine

            Moragaine Existential Complex

            I have no clue.. Everything loads on my game with no problems. Could you upload your error file here and post a link to it. I'll try and figure out what's happening.. (pretty sure it's related to the game updating yesterday)

            Update: I updated SdV and relevent mods. Your mod still loads after the updates so it's something else that's broken.
             
              Last edited: Mar 2, 2019
            • cankersaur

              cankersaur Big Damn Hero

              Sorry I've been screwing things up. The game was able to start this time, but the changes didn't take.

              Here is the log.

              The relevant bit:

              Which sucks because when I tried having blank fields for EntryDll and ContentPackFor it *also* wouldn't load.
               
              • Moragaine

                Moragaine Existential Complex

                You won't have a .dll for it, those go in Smapi mods. This is a copy of the manifest that I used to get the mod to load, you can compare the 2.
                 

                  Attached Files:

                • cankersaur

                  cankersaur Big Damn Hero

                  Hmm, I still get an error message.

                  I'm so sorry for being this much trouble. Thank you for all of your help with this. Please let me know if I can buy you a coffee or something.
                   
                  • Moragaine

                    Moragaine Existential Complex

                    No worries, I like puzzles... lol I also like to see new things in game. For the Content.json that was just adding a pair of brackets [ ] - one right after and one just before the last curly brace:
                    {
                    "Format": "1.6",
                    "Changes": [
                    {
                    "Action": "Load",
                    "Target": "Maps/Saloon",
                    "FromFile": "assets/Saloon.tbin"
                    },
                    ]
                    }

                    like so. Well, with indentations.. You could try using Notepad++ or Sublime, text editors which make coding errors easier to spot.
                     
                    • cankersaur

                      cankersaur Big Damn Hero

                      Thank you! I use Notepad++ but I'm just quite clueless, haha.

                      Right now I have it like this, but it's still giving me an error code.
                      [​IMG]
                      I tried it with and without the [brackets] aligned. No joy.

                      Edit: noticed the line 1 curly bracket was not supposed to be there. Removed it. Still no luck. :(
                       
                        Last edited: Mar 3, 2019
                      • Moragaine

                        Moragaine Existential Complex

                        There's an odd curly brace just above the lower bracket that shouldn't be there. The various brackets and braces all come in pairs, so if there's an odd one you're either short something or have too many of something. Notetab++ highlights each pair in red when you click on one of a pair; you can see in your screenshot where the bottom brace thinks it's paired with one just above it, rather than the one at the top, which is it's actual mate.
                         
                        • cankersaur

                          cankersaur Big Damn Hero

                          Ohhh, I see. Thank you! That makes sense. Let's give it a shot!

                          Edit: it technically loaded, but then crashed.

                          https://log.smapi.io/ADZBEbP1

                          I tried making the tileset used the one in the assets folder instead of my pictures folder but I still get the same error.

                          Edit: I'm trying to figure it out. This looks helpful but it might be a bit over my head.

                          I copied the tilesheet into content/maps and content/tilesheets for good measure. Trying again!

                          Edit: no luck.

                          Edit: huge thanks to Zola [Opalie] on the Discord for pointing out how I screwed up the thing, haha.

                          Solved!
                           
                            Last edited: Mar 3, 2019
                          • Happy1816

                            Happy1816 Aquatic Astronaut

                            Hi, I am in the same situation and having issues loading my game with a vanilla tilesheet I added to a farm mod map I am editing. States same thing about "Tilesheet paths must be a relative path without directory climbing (../)"

                            I've tried looking at that same site you posted but also over my head. I've added the tilesheet .png into content/maps, content/tilesheets, and to the mod's folder itself. Issue persist! Do you mind posting how you resolved the issue please?
                             
                            • Ciustek

                              Ciustek Space Hobo

                              I'm having the same problem as cankersaur ,I have a created a custom farm map but when I try to load it I get this error " Tilesheet paths must be a relative path without directory climbing (../). ". Does anybody here has a solution to this?
                               
                              • auspiciousAscention

                                auspiciousAscention Space Hobo

                                I'm also having a problem with that. I must've tried changing the files at least 50 times, and every time I run it it gives me the same error. How do I fix this?
                                 

                                Share This Page