Bug/Issue [Bug]Unit.getMedkitNumber(Unit.java:613)

Discussion in 'Support' started by Ohmnivore, Nov 27, 2014.

  1. Ohmnivore

    Ohmnivore Space Hobo

    In the mission that Sam suggests to scavenge for food (also the one right underneath the "recover old hyperjump report" on the map), whenever I open Lannis's "ring" menu I'm greeted by this pleasant message. It happens regardless of turn and it still happens if I happen to take all the medkits away from his inventory. I tried three times, still the same.

    Bug description:
    OS: Windows 7 x86, version 6.1
    number of processors: 1
    system property hash: 0xd461df52
        at com.robotality.halfway.objects.Unit.getMedkitNumber(Unit.java:613)
        at com.robotality.halfway.ui.newUI.RingUI.setUnit(RingUI.java:553)
        at com.robotality.halfway.ui.newUI.GameUI.showRingUI(GameUI.java:1918)
        at com.robotality.halfway.gamestate.states.human.UnitTurnBased.enter(UnitTurnBased.java:46)
        at com.robotality.halfway.gamestate.GameStateManager.changeState(GameStateManager.java:133)
        at com.robotality.halfway.gamestate.GameStateManager.update(GameStateManager.java:67)
        at com.robotality.halfway.game.Game.update(Game.java:220)
        at com.robotality.halfway.screen.GameScreen.update(GameScreen.java:215)
        at com.robotality.halfway.Halfway.render(Halfway.java:89)
        at com.badlogic.gdx.backends.lwjgl.LwjglApplication.mainLoop(LwjglApplication.java:207)
        at com.badlogic.gdx.backends.lwjgl.LwjglApplication$1.run(LwjglApplication.java:114)
    Display Modes:
    loaded from config: 1280x720x32 (60 hz)
    desktop resolution: 1366x768x32 (60 hz)
    [DOUBLEPOST=1417051406][/DOUBLEPOST]Also I can't provide the error message for it, but my game crashed when I tried to inspect the dummy targets (it was a really early level). I sent you the error log back when it happened, if that helps.
    • Seminus

      Seminus Halfway Developer Developer

      Thanks @Ohmnivore for reporting. What version of the game are you running at? And do you have any Mod active while playing?
      I will try to reproduce it, but any additional information will help.
      Also Can you provide some details about your system? (OS, CPU, GPU etc...)

      Share This Page