1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Bug Thread Risk of Rain 1.0.0

Discussion in 'General Discussion' started by Vizjun, Nov 8, 2013.

  1. Willy

    Willy Void-Bound Voyager

    On my little brothers General Stats page, it says he's played as the Enforcer 4 times, when he doesn't even have enforcer unlocked. He did play a couple games with me in which I had played as the Enforcer, but certainly not 4. (Online, not Local.)

    I'm not sure if that's supposed to happen or not, but even if it is it's a bit confusing.
    • Syzygy

      Syzygy Big Damn Hero

      So no body else is having the "Can't even play the game" issue? *sigh*

      Maybe this game shouldn't have been so hasty to exit beta
      • NightFire

        NightFire Parsec Taste Tester

        "Steam access violation at address #######(i found out it's always different so just fill in # with whatever address it gave you) in module 'Steam_GM.dll'. Read of address 00000000."

        -.- always think inside the box before outside the box...

        Solution: Navigate to the Risk of Rain folder inside your steam folder (Program Files(programs x64 for windows 7 i think)>Steam>SteamApps>Common>Risk of Rain
        than go to the _CommonRedist folder THAN vcredist
        Now this is where it gets simple
        go to both 2008 and 2010 and run the vcredist_x64 (vcredist_x86 if you use windows XP like me) then just set it to repair (or install if you haven't... which would be pretty odd) and restart your computer

        so far this fix has been working perfectly for me and im getting 0 lag (the only recurring issue is the first time set up thing but i can easily overlook that in fear i might screw something up)

        now im off to solve the mystery of the freezing online coop bug
        that was a "can't even play the game" issue just try what i said above and see if it works
        • BlueJello

          BlueJello Space Spelunker

          I am getting a error when trying to connect to a certan server, not getting it on other ones,
          error message is below
          ERROR in
          action number 1
          of Alarm Event for alarm 5
          for object objClient:
          In script client_message_send:Error in code at line 79:sendmessage(objClient.sock); ^at position 24: Unknown variable sock
          • Taekon

            Taekon Void-Bound Voyager

            My game runs really slow and there's no "Pixel-perfect Scaling" in the options. I got the beta version and it ran quite smoothly.
            • beforearth

              beforearth Space Hobo

              Bought on Steam.
              The game has no sound, completely.

              ERROR in
              action number 5
              of Create Event
              for object oInit:

              Error defining an external function.
              • meow247

                meow247 Pangalactic Porcupine

                is the commando's unlockable 'dodge 7 lethal attack' broken? i've been dodging lots of attack and i cant seem to unlock it. i've tried 1v1 dodges with a magma worm and it's still locked. what count as lethal?

                also i cant get the '1-shot 10 enemies consecutively' for sniper unlockable. does it have to be full health enemies for it to count or enemies that was hit by the penetration shot also count?
                • BlueJello

                  BlueJello Space Spelunker

                  Pretty sure pixel perfect scaling is the surfaces option
                  • beef623

                    beef623 Void-Bound Voyager

                    I'm having some issues with the controller support. Everything worked great throughout the beta, but with the release version it's not working. With the default buttons the right trigger is pausing the game. When I try to remap a button on the controller it immediately sets it to either "Axis num.0 Backward" or "Axis num.4 Backward" and I get the following error in the error log:

                    ERROR in
                    action number 1
                    of End Step Event
                    for object oMenu:

                    Error in code at line 84:

                    joy_setting[change_joy-1,0]=2 //hat
                    at position 38: Negative array index
                    • DeBunny

                      DeBunny Void-Bound Voyager

                      Lethal attacks are attacks that would have made you lose if they hit you.
                      I usually get that unlock by jumping in a horde of enemies at low health and dodge-rolling away. Tends to be all seven-dodges in one go.
                      • Matanui3

                        Matanui3 Phantasmal Quasar

                        I got two imp tentacles in one run today, but I never saw a friendly imp.
                        • Crimbo Hardstyle

                          Crimbo Hardstyle Big Damn Hero

                          When you die as the mercenary, your corpse turns into the dead miner sprite instead of having a unique one.
                          • meow247

                            meow247 Pangalactic Porcupine

                            you've unlocked him already?!:whaaat: damnnn. can you post a pic of his ability and such at the char select menu? i wanna see :pwease:
                            • Currently, my I finding that RoR will only save my achievements, nothing else. Also, it seems to be impossible to unlock anything in the monster and item logs. I have tried deleting my save, but this has had no effect.
                              • needsomemiracle

                                needsomemiracle Scruffy Nerf-Herder

                                I've encountered the same on the temple level. I was walking across the field and saw the stone golem (?) money shrines all blown up and thought that was just for the entourage.
                                • Neurawr

                                  Neurawr Space Spelunker

                                  Yeah my progress just resets everytime I exit the game, and the save.backup doesn't change anything
                                  • Neurawr

                                    Neurawr Space Spelunker

                                    Health shrines breaking on TP activation is intended .. sadly
                                    • Cyriel

                                      Cyriel Pangalactic Porcupine

                                      - Random error with no apparent effect during multikill of elites. (could be helpful)
                                      - Fullscreen is only half full. Steam overlay is incredibly zoomed in / mispositioned and duplicated with the mouse not able to properly align with the overlay functions. (screenshot at bottom)
                                      - Damage is displayed more than once if an attack hits a drone. (Eg: Saw a drone take 2x 112 damage but not get destroyed or damaged a lot) Happened more than once but could have mislooked.
                                      - Golem boss sometimes walks through solid pillars but doesn't always do this. Not sure if this is intended.



                                      In both screenshots the mouse pointer was exactly on the arrow dropdown button, yet shows itself in a completely different location. The 2nd window in the background is the duplicated ghost window that shows up in 2x size, possibly thanks to the scaling from the in game settings. The lower menu is also pushed down and adjusted offscreen to the right. Also the steam screenshot negates the parts of the screen that are black so for reference check the windows screenshot.

                                      All of this came from 1600x1200 res windows XP sp3.

                                        Attached Files:

                                      • Venom

                                        Venom Pangalactic Porcupine

                                        The achievement killing a boss with the ''Lights out'' skill doesn't seem to work.
                                        EDIT: Small visual thing:


                                        The rope isn't as long as the part you can climb on.
                                        • Pizzarugi

                                          Pizzarugi Scruffy Nerf-Herder

                                          The latest issue since their patch last night: No audio, at all. Verified game cache and everything, but nothing's happening to fix it.

                                          Share This Page