1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Bug reports for Risk of Rain 1.0.2

Discussion in 'General Discussion' started by needsomemiracle, Nov 11, 2013.

Thread Status:
Not open for further replies.
  1. Treadlight

    Treadlight Existential Complex

    Well, there's always the 'Verify Integrity of Game Cache' button.
    • joey4track

      joey4track Ketchup Robot

      That didn't do anything, that I could notice anyway. Still 1.0 :confused:
      • Duffie

        Duffie Orbital Explorer

        Right. Accidentally posted this in an old bug report thread. So...


        I get the same "Floating point division by zero." error, but it just ends up erasing all of my info, except my achievements.

        From looking around on Google, I've noticed updates have fixed this issue, but I'm not exactly sure how they fixed it.

        Does anyone know what I should do, in general? I'd like to not lose everything I just got... Again...

        Edit: Here's a picture of the error message.

        This appears in the center of a black screen, right after it goes to fullscreen to load up the game.

        Edit Edit: I have a dual screen setup, so I didn't want to desktop screenshot, but just so you know exactly...


        I hope you guys can solve this issue. :<

        EDIT: Also, thank you @Chthonic One for pointing me in the right direction, and not yelling at me for being the moron I am. :love:
        • Megadog

          Megadog Astral Cartographer

          Had this with both the ancient wisps and collosus on the 2nd or 3rd stage, at around 10-15 mins.
          (2x wisps on 2nd in one run, 2x collosus on underwater stage in another)

          INTERESTING BUG -> You don't take fall damage from any height if you're holding down the jump key as you land.
          • Chthonic One

            Chthonic One Aquatic Astronaut

            That's not true. You likely had rusty jetpacks. These will only reduce your fall speed if you hold the jump key. However you will still eventually reach max velocity and take damage. Holding jump key without one has no effect on whether or not you take damage.
            • Shwez

              Shwez Aquatic Astronaut

              Mercenary's Eviscerate can crits but cannot proc Wicked Ring. Bug? Deliberate?
              • needsomemiracle

                needsomemiracle Scruffy Nerf-Herder

                Sawmarang and Missile Launcher icons are shrinked down and aligned to bottom-right corner while on cooldown. When the item is ready for use, their icons appear as normal.

                2013-11-15_00001.jpg 2013-11-17_00004.jpg
                • Plagerist

                  Plagerist Intergalactic Tourist

                  Not sure if this is the right area to post, because this seems to be an abusement of the Providence boss AI. I was on 2x scale.
                  As bandit, if you use his smokebomb ability when fighting Providence, and move to the either side of him, so he just on the edge of the screen, when you reappear he doesn't target you, he just walks idly left to right, so you can just attack him without him retaliating at all due to the bandit's range. This works on both his first and third form and I've been able to reproduce the bug 3 times.
                  • Gilgermesh

                    Gilgermesh Space Hobo

                    I was playing yesterday, and I got an unusual error. I can only jump straight up with a character and it moves at a rigid and slow pace left and right whenever i try to move. All abilities are fine, however. There is seemingly no money displayed, and the difficulty and time bar is left with just a column of the different colors with no timer or difficulty indicator. In addition, the error below was recorded in the game's files.


                    ERROR in
                    action number 10
                    of Draw Event
                    for object oHUD :

                    Error in code at line 41:

                    at position 99: Division by 0.

                    I've tried verifying the game's steam cache and reinstalling it, but neither one fixes the problem. Not sure if this was solved or not already, but has anyone experienced something like this or know a fix?

                    Edit: Fixed itself by switching to a different difficulty at the character select screen.
                      Last edited: Nov 17, 2013
                      CalamityCarbine likes this.
                    • jakrodriguez

                      jakrodriguez Void-Bound Voyager

                      I have a serious bug and it involves my monster log and item log. Whenever I leave the game on any save file my monster log and item log gets erased my characters that i have unlocked are still there.
                      But the Item log has nothing and when i say nothing I mean literally nothing no silhouettes of any items just nothing. My monster log is there but any previously collected monster log disappears.
                      Deleting my save file is a temporary fix but after starting the game up and then leaving it happens again. This has happened on 1.0.0 and 1.0.1, i'll leave the error message as an attachment.

                        Attached Files:

                      • Chthonic One

                        Chthonic One Aquatic Astronaut

                        Question, are you looking at the timer for eviscerate or the timer for your other skills? Eviscerate doesn't go on cool down till after the last hit lands so it won't affect it's own timer I don't think.
                        • V3nom

                          V3nom Starship Captain

                          Today the double-canceling-chargefield-generator-bug seems to be fixed, but I'll ask a stupid question : Where can you see your version on Steam ? Even searching in files in the folder I cant find any Version number. (And I didn't managed to find a post about that on the forum)
                          • needsomemiracle

                            needsomemiracle Scruffy Nerf-Herder

                            Had a stone golem die mid-air and his remains stuck mid-air too. This happened off-screen so not sure what actually led to this.

                            • JoeyAsagiri

                              JoeyAsagiri Intergalactic Tourist

                              The usual items get stuck in walls and unable to obtain bug, but I also noted something different:

                              I am not sure if its a bug or a feature because I can't find anything about this, but on monsoon, around the I SEE YOU/I'M COMING FOR YOU difficulty at the water level there where Invisible shadow enemies? Like they where invisible and when I attacked them they became black for half a second then become invisible again, I attacked them for atleast 30 seconds but they wouldn't die. (they also had no health bar, only a blue arrow ontop of them when I attacked them). It was also that the only mobs that where like this where like this where sand crabs and clay men (but their normal visible/killable counter-parts still spawned). I can't say much else because I got killed by one of the invisible sand crabs from around 600 hp as a huntress, there where only 2 enemies attacking me so I assume the shadow sand crab does about 500 damage a hit, pretty sure the normal one does not do that much damage.

                              Another thing I noticed was in the sky meadow (same game as the one where I saw the shadow enemies) that after beating the boss from the teleporter spawn a boss bar came up again and the name was something allong the lines of: "Phantom golem" (not entirely sure), however the bar then quickly dissapeared when I killed a bunch of normal mobs, It didn't seem to drop down while I was killing the mobs so it must have been some leftover code for a scrapped/new boss?
                                Last edited: Nov 17, 2013
                              • Burby

                                Burby Phantasmal Quasar

                                I just noticed that my game didn't even update. That is, while I can't find anything ingame declaring the game's name as version 1.0.1, the file properties when I browse the files say So before I decide to remove and redownload the game, I'd like to know if the save file will stay, or if not, properly carry over to this version if the save is inserted into the game folder manually?
                                • Treadlight

                                  Treadlight Existential Complex

                                  I'm terribly sorry, but I feel the need to mention that you seem to have wrote the word 'where' in place of 'were' a number of times. It's really hard to read your post when I can't tell which is which.
                                  • Stovepipes

                                    Stovepipes Void-Bound Voyager

                                    Those are blighted enemies, regular enemies that are treated as bosses within the game. The "bugs" you thought you were experiencing are traits that distinguish blighted enemies from normal enemies. They didn't have a health bar because they should've had a boss health bar at the top of the screen (like any other boss).
                                    • joey4track

                                      joey4track Ketchup Robot

                                      Same for me and same question :)
                                      • Chthonic One

                                        Chthonic One Aquatic Astronaut

                                        Same for me, however I did notice that the file was last altered on the date this thread was created. I however obtained the steam copy on the 8th, so some update did in fact happen.
                                        • Stickman1

                                          Stickman1 Phantasmal Quasar

                                          I'm getting an steam_GM.dll error everytime I launch the game ...
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page