1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Bug reports for Risk of Rain 1.0.2

Discussion in 'General Discussion' started by needsomemiracle, Nov 11, 2013.

Thread Status:
Not open for further replies.
  1. TheVague

    TheVague Space Hobo

    Bug 1: A monster log appeared in a wall(it dropped from a flying creature) and there was no way to get it.
    Bug 2: You know that game closes sometimes? It also closed when I opened League of Legends (fullscreen) but it didn't close when I opened mincraft (fullscreen and windowed)
    • Mr Steam

      Mr Steam Space Hobo

      Hello, first time poster; owner of Starbound and Risk of Rain.

      I've been having some problems with Risk of Rain.
      First off, the game looks great and I was happy to pick this up in the Steam Sale. However, there are numerous problems that make the game unplayable.
      I have a Logitech F710, the same as pictured in Steam's Big Picture advertising. I usually keep it switched to XboX360 mode as games simply recognise it as an XboX360 controller.
      • Risk of Rain refuses to let me use the controller in this mode
      • When the controller is switched to this mode, keyboard input is turned off!!??!!
      • When switched to direct-input, and binding the gamepad manually, the controls work
      • But the game does not recognise diagonal input!!???
      • This makes jumping onto ladders impossible if you do not have the ninja-reflexes to press up at exactly the correct pixel-perfect moment that the character passes the ladder if jumping to the left/right
      • Even when jumping vertically, and overlapping the ladder, the character does not grab on unless he is in the pixel-perfect position
      • This is the same for descending onto a ladder; often the character refuses and you must inch to the right, press down, inch to the right, press down, try inching to the left, press down, inch to the left more, press down again.. it is maddening!
      • None of the ladders are attached to the ground, which requires jumping to grab on
      • For a game on a tight timer, most jumping onto ladders will be to the left/right
      • The game is impossible to play until this is fixed, let alone to play on any kind of time limit
      • When the player holds up/right, the game should register both up and right; up/left should register as both up and left; down/left should register as both down and left; down/right should register as both down and right
      • This is basic input 101
      My controller works fine in all other games that support XboX360 controllers, and even in direct-input for those rare games that still support this mode.
      This is the only game that has problems. To get the XboX360 mode working I've restarted the game several times, while holding/pressing different combinations of buttons on the controller; I've switched the input mode back and forth; I've changed the batteries..
        Last edited: Jan 5, 2014
      • Elijin

        Elijin Void-Bound Voyager

        I encountered a visual bug with the Engineer.

        after attaining

        2 x Wicked Ring
        2 x AtG Missile Mk2
        4 x AtG Missile Mk1
        3 X Alien Head
        And a Crit rate very very high.

        At this point I was able to fire the 3 missile salvo bound to his 'C' power as quickly as I could press it. During the 120 second countdown, with about 5 sets of Engineer missiles on screen and god knows how many AtG Missiles, all further missile animations stopped happening. This continued for the rest of the match. Note the missiles still dealt damage to enemies, they just were no longer visible.
        • Treadlight

          Treadlight Existential Complex

          Ahh, I remember this problem. I reported it a long time ago, and the reasoning was told to be that GameMaker is not the best at POV. Any input device that uses POV will only be accepted as having one input at a time. Troublesome for controllers that use POV for D-Pads. What I did to solve this was: Set the movement controls to the left analog stick and turn off the 'analog' mode. This makes the D-Pad give analog stick input instead of POV input. I use a PS2 controller so it's just a button that says "analog" on it; Logitech controllers have a switch on the back that says "mode."

          EDIT: I am bad at commas.
            Wasd_wasd, Mr Steam and Auraknight like this.
          • ranmafan

            ranmafan Big Damn Hero

            I often get trouble with boss spawns - it takes too long to create one and then in one instance it created TWO despite being on normal difficulty (main) and 'medium' in the risk meter. Here's the latest log.

              Attached Files:

            • BeAuMaN

              BeAuMaN Orbital Explorer

              Yeah, I was happy to finally stop losing my progress as well. Wish they'd save your achievement progress after every level. Anyhoo... I remembered reading now that Risk of Rain uses Gamemaker as its engine... that would explain the EAX issues. I've had to disable surround/EAX for most other Gamemaker engine games... So really this is probably a longstanding problem with the engine itself, granted those games would give me some different errors.
              • Chthonic One

                Chthonic One Aquatic Astronaut

                Sounds auto quality control turned down the quality level on you. The missiles don't go invisible, they just look different and are kinda hard to see.
                • Mr Steam

                  Mr Steam Space Hobo

                  Thanks for the tip; I'll definitely try this. Though I'd be happier for the game to just recognise it as an xbox-360 controller, rather than having to switch it to direct-input.
                  • kingrea

                    kingrea Space Hobo

                    So my mate hosted a game (playing over hamachi as internet games doesn't work for us). I'll join but whenever we get up to level 3 or so my guy stops being able to walk when I hold down an arrow button. He'll only move frame by frame for every time I hit the key. I've attached the error log here. Cheers.

                      Attached Files:

                    • Elijin

                      Elijin Void-Bound Voyager

                      Not 100% sure what happened here, but I went afk to get the 25min above 70% achievement, and when I came back my shield cap had risen to double my health. I think maybe because I was healing with the fungus as the missiles hit, it raised the cap on the shield or something? Either way, this was weird.


                      Edit: By the end of the 25minutes my health was 50thousand. Didnt get a second screenshot though. Also dont think I got the achievement?
                        Last edited: Jan 5, 2014
                      • Noya

                        Noya Space Hobo

                        If you use The Explorers Key in the last level, and you happen to open a golden container, the keycard will drop through the ground .
                        • Matanui3

                          Matanui3 Phantasmal Quasar

                          Playing on drizzle today (to try to clear with Sniper), I was in Medium difficulty (17 minutes, 3rd stage), and a boss spawned by itself.
                          Then I hit the teleporter and no actual boss spawned; a Scavenger spawned instead.

                          Is this a bug or is a scavenger as a boss something that happens in drizzle?
                          • Brassqund

                            Brassqund Hard-To-Destroy Reptile

                            Scavenger is a boss.
                            Also, boss spawn like normal monster... but with a really more lower chance to spawn.
                            The more the difficulty is high, the more the chance is big but you can see one really early if you are (not) lucky.
                            • ranmafan

                              ranmafan Big Damn Hero

                              1) Activating the teleporter before collecting money (from say a recently deceased enemy or opened container) will cause the money to not be converted to XP and instead carry over to the next game.
                              2) Using an Unstable Watch then quitting and starting a new game will cause the time stop effect to carry over to the new game.
                              3) Teleporters sometime share space with a jump pad.
                              4) Colossus can spawn rock golems INSIDE a wall (notably reproducible in Dried Lake) making the level unwinnable without special items.

                              Attached a screenie of the offending bug for (4).

                                Attached Files:

                                Last edited: Jan 7, 2014
                              • wilflare

                                wilflare Space Spelunker

                                RoR does not work with xbox360ce :(
                                having issues with the default Gamepad control setting as well
                                • Matanui3

                                  Matanui3 Phantasmal Quasar

                                  I was under the impression that Scavenger was not in the normal spawnlist for the level boss for any of the levels, especially since I hadn't ever seen it as one before.
                                  • Madosuki

                                    Madosuki Pangalactic Porcupine

                                    Can't host online co-op after most recent patch get the following error in error log after startup.

                                    ERROR in
                                    action number 1
                                    of Create Event
                                    for object oInit:

                                    Error defining an external function.
                                    • Calcifyre

                                      Calcifyre Space Hobo

                                      Can't move during an online game.
                                      Playing as Enforcer, don't know exactly what caused it.
                                      • Chthonic One

                                        Chthonic One Aquatic Astronaut

                                        Scavenger is a rare boss that can spawn on almost any level.
                                        I say rare because you almost never see him prior to high difficulty timers. However he is a boss. Any enemy which makes a bar across the top of the screen on Rainfall is a boss type monster. On monsoon blighted enemies also produce a health bar, but aren't treated quite like bosses in all regards. One way is if spawned prior to the countdown, they can in fact despawn if left behind unlike a boss.
                                        • Mistapickles

                                          Mistapickles Space Hobo

                                          I recently got this game for my girlfriend to co-op with and we were playing just fine yesterday with me hosting the game and her connecting to my server. However, today we tried to to the same thing, but whenever she tries to connects it says "failed to connect" even though other people are able to connect to my server. We are on the same connection and we've tried using the internal ip as well as the external ip. Please help as I would like to be able to continue playing with her.
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page