1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Bug reports for Risk of Rain 1.0.2

Discussion in 'General Discussion' started by needsomemiracle, Nov 11, 2013.

Thread Status:
Not open for further replies.
  1. Arisonas

    Arisonas Intergalactic Tourist

    Not sure if this has been posted but I was playing MP with my friend fine using hamachi then after i tried rehosting after a break it kept coming up that my port was closed. I've tried uninstalling and reinstalling hamachi several times, using actual port forwarding from my router, resetting my router, uninstalling and reinstalling risk of rain, making sure that the firewall had the correct exceptions etc. Whatever I do I can't seem to get the port to open up at all.
    • BrutorDragon

      BrutorDragon Tiy's Beard

      I have the multiple screen problem too. I have 3 screens, and I cannot play RoR withut it being smaller. And there is no way to force it.
      • Brassqund

        Brassqund Hard-To-Destroy Reptile

        Strange little bug.
        During a game, I got the Imp overlord's tentacle and
        when he attack a monster, money had start spawning even if the monster was not dead.
        That had continue until the monster die and after that, no more bug (but a got 2000 gold from ONE monster)
        Image with which Item I had.
        • meow247

          meow247 Pangalactic Porcupine

          feature. there are a few varieties of the imp buddy. 3 maybe?
          1st is normal, 2nd is explosive and 3rd has a pillage gold effect
          • Lotus Gramarye

            Lotus Gramarye Master Chief

            When I start the game the music won't play and I get the following error report.

            ERROR in
            action number 5
            of Create Event
            for object oInit:
            Error defining an external function.
            • BrutorDragon

              BrutorDragon Tiy's Beard

              Is there a file i can change or a line of text i need to add to make the game start in windowed?
              • meow247

                meow247 Pangalactic Porcupine

                prefs file > video options

                [Video Options]

                0=off, 1=on
                • BrutorDragon

                  BrutorDragon Tiy's Beard

                  I did that but even in windowed it goes to some ridiculous resolution.
                  Is there a line i can add to change the resolution?
                  • meow247

                    meow247 Pangalactic Porcupine

                    try this:

                    1=small, 2=medium, 3= large
                    • BrutorDragon

                      BrutorDragon Tiy's Beard

                      that fixes the size, but now its just messed up in a smaller box.
                      The resoution, need fix for resolution. Not scale.
                      Thanks though.
                      • Treadlight

                        Treadlight Existential Complex

                        What? What do you mean "messed up?" You kind of need to be more specific.
                        If you mean the black area, then that's supposed to happen. There's no screen resolution setting at all, since the game uses a fixed perspective. The only thing that your screen resolution affects is the scale. This game seems to hate 21:9 monitors for some reason, it assumes you have a 16:9 one.
                        • BrutorDragon

                          BrutorDragon Tiy's Beard

                          No I mean, i have 3 screens. All connected. For some reason the resolution is defaulted to the highest. And in my case its a resolution that requires 6 screens.
                          and yes all three are 16:9
                          • Paradox244

                            Paradox244 Space Spelunker

                            I am also having the problem where I start up the game and it just sticks on a black screen and never loads. I am using Windows 8 64 bit.
                            • MacAero

                              MacAero Space Hobo

                              Hello peeps.
                              I was playing online mp with my friend today. I was hosting. We were playing on LAN (i.e. our computers were hooked up to the same router via ethernet cables). At some point the game crapped itself on my end. I couldn't move, use abilities or even esc to menu. On my friends end he could move VERY slowly and use abilities. What is interesting that this error was probably triggered by him losing one of his drones. Afterwards he was "losing" drones all the time i.e. drones would spawn and instantly die. You can see that in his screenshot [​IMG]. Unfortunately I couldn't even take a screenshot. There was no error file recorded. Damn shame we had a good run and this is a major turn off.
                              • ShadowlessWanderer

                                ShadowlessWanderer Pangalactic Porcupine

                                Unsure if its been stated or even if its a bug but with the Imp reward statues (pay X amount of gold, it spawns 5-10 imps that you have to kill before time runs out to get an item) sniper has absolutely no way to hit them at all. All of his shots go right above their hitbox and the only way to actually even have a chance to get the reward is to hope the imps frequently jump. Again, totally unsure if its been stated and is an actual bug (seems more like a hitbox error to me) but thought I would just point it out either way.
                                Thanks for the great (if not time consumingly addictive) game that I can't stop playing.
                                • DarkStopDying

                                  DarkStopDying Intergalactic Tourist

                                  Just Purchased. Game won't even launch for me. I get "Access violation: in module Steam_GM.dll. Read of address 000000000. Disk does not need to be defragged. repaired visual C++ as well as uninstalled and reinstalled. Uninstalled and reinstalled game. Verified integrity of game cache I am at a loss.
                                  • Chthonic One

                                    Chthonic One Aquatic Astronaut

                                    That sounds like the Steam overlay. Try disabling it in Steam. If that doesn't work, delete steam_GM.dll and copy one over from a game with a good copy.
                                    • DarkStopDying

                                      DarkStopDying Intergalactic Tourist

                                      Turned it off. No luck. Also checked other games but didnt find a similar file. Any tips so i can maybe edit it to a better state?
                                      • Chthonic One

                                        Chthonic One Aquatic Astronaut

                                        Strange. Looking at the virus reports for the file (It's safe, don't worry), and other stuff, it seems to be a rarely used DLL for the overlay. Usually most games use Steam_api.dll instead, but Risk of Rain uses both. I don't know why, Hopoo would have to tell us. However I do know that Wanderlust Rebirth also uses Steam_GM.DLL

                                        The following function calls are available with Steam_GM.dll:
                                        The following function calls are available with Steam_api.dll
                                        As I said, most steam games seem to use the second only. They have different functions though. Perhaps it is a problem where both Steam and Risk of Rain are making the steam overlay at the same time.? Most games usually let Steam manage the overlay, but I've noticed that the overlay gets shown twice on Risk of Rain, once normal sized, once double or tripled if you have 2x or 3x activated. Maybe Hopoo needs to stop trying to hook the overlay himself, and that might fix the problem. Just brainstorming here, but I do know that Steam can and will give overlays for non-Steam games as well, and that's what Steam_GM.dll is used for.

                                        Then again, the only place on MY PC I can find Steam_GM.dll is in Risk of Rain's folder. Perhaps it's a special version of GameOverlayRenderer.dll or GameOverlayUi.dll for DX8 games? I'm having problems getting an analysis of those currently as the scanner is being slow, but those are actually used in actually creating the overlay.
                                        • nNa

                                          nNa Intergalactic Tourist

                                          I can confirm that Razer Onza (Tournament Edition) works fine with 1.0.2.
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page