1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Bug reports for Risk of Rain 1.0.2

Discussion in 'General Discussion' started by needsomemiracle, Nov 11, 2013.

Thread Status:
Not open for further replies.
  1. Alucard I

    Alucard I King Homestuck I

    One more bug:
    Items needed:

    • Time Keeper's Secret
    • Imp's Tentacle
    Bug: After getting both items and activating the TKS, imp freeze, and then go somewhere else, ceasing helping you. It doesn't teleport to you anymore. It doesn't appear on next levels.
    EDIT: Found what was he doing. The imp continues moving in the direction it was moving when the time was stopped until it reaches any wall. Then the imp stops.
      DeadlyLuvdisc likes this.
    • needsomemiracle

      needsomemiracle Scruffy Nerf-Herder

      Ah, I see. Haven't found the scepter yet.

      P.S. prance - to walk or move in a lively confident way that may seem silly or annoying to other people
      • warlocked200

        warlocked200 Starship Captain

        I got an Ornate worm monster log and he doesn't show up in the Bestiary section. Is his yet to be implemented?
        Same question for a certain item, the shirt you get from the pig, is that just an easter egg because it doesn't show up on my item log.
        • Burby

          Burby Phantasmal Quasar

          For as far as we've currently been able to tell, items with a purple border do not appear in the item log. I know of 3 such items so far, one of which hasn't been found in the current version.
          • Vizjun

            Vizjun Starship Captain

            Ancient Scepter (To The Skies is now 6*180%) + Wicked Ring x2 (critical strikes reduce cooldown by 2 seconds) + 100% critical chance + Shattered Mirror. Also Predatory Instincts was helping a lot, it made it even more spammable.

            And as meow247 said, there is a limit. Passive cooldown reduction can't be less than a second. But the two Alien Heads helped reducing it to 2 seconds.
            • Alucard I

              Alucard I King Homestuck I

              Hit list bug: Marked enemies, when falling off the screen, don't increase counter.
              • Archalieus

                Archalieus Scruffy Nerf-Herder

                If Ifrit suffers from KB, he ignores all terrain on his plane, including gaps.
                • warlocked200

                  warlocked200 Starship Captain

                  There is an error in the Whorl monster log, the description says; "...the hard shell of a monstrous gWhorl h nearly compromised my air lock..."
                  Just a little error.
                  • BonusLord

                    BonusLord Void-Bound Voyager

                    Used Acrid's Epidemic ability on the ornate worms and it slowly brought the whole game down. Was a joiner in a 4 player online co-op game and was the sole survivor at the time of the fight. The poison seemed to infect all segments of the worms but the once a certain number of segments were infected, the worms' health started going up instead of down. One by one the other players' game clients crashed and finally mine crashed as well.

                    Worth noting is that I used the same ability on the worms in a solo game and didn't experience any problems.
                    • P.Alex

                      P.Alex Industrial Terraformer

                      Sniper's SCAN doesn't trigger completely on Magma Worms. Not staying on them while they're down under aside, the critical damage only applies to the head of the worm rather than the whole body.
                      • Dennis

                        Dennis Subatomic Cosmonaut

                        This has probably been reported already, but picking up 2 Chargefield Generators makes it stop working altogether.
                          RedWiz likes this.
                        • Ipo

                          Ipo Seal Broken

                          I played this game for the first time today (love it!) and I was playing co-op.
                          We entered the teleporter on third level (after clearing the stage) and the game instantly crashed for me before the transition to the next level. We tried again and it crashed at the teleporter for the first level, same happened on the next try. I restarted pc, crashed on teleporter of third level. I disabled SLI, same problem. I tried compatibility (Im running windows 7 64 bit) set to windows XP service pack 3, same problem. Tried windowed mode, same problem. I reinstalled the game and everything seemed to go fine but I had no sound so I reinstalled the vcredist (as suggested in this forum) and I got my sound back. I decided to play solo for a bit, got to the teleporter on the forth level (after clearing the stage) and my game crashed.

                          EDIT: After further testing with this bug it seems that the sound may be related to it, that or its just coincidental. I will start the game with music in the background, all weapon sounds and all other sounds are fine. On the second or third level the background music will no longer be playing. The level after that the sound will have stopped completly and nothing will be heard. On this level the teleporter will cause a crash. Upon restarting the game there will be no sound what so ever which can be solved by the solution in this forum. I have done this entire sequence four times now so I'm assuming its not a coincidence.

                          Fix: Im embarassed to say but it was a sound issue. I have the Asus Xonar D2X Audio Center and the solution was turning GX mode off. The game runs perfectly fine now. I didnt even know GX mode was on!
                            Last edited: Nov 16, 2013
                            SteelSoldier likes this.
                          • Av3nged

                            Av3nged Space Penguin Leader

                            Sniper scope targets ghosts, wasn't able to get a screenshot though.
                            • Vahnkiljoy

                              Vahnkiljoy Ketchup Robot

                              The "Die 50 times" Achievement does not work still. Ok, it WORKS, just not tracking properly, I got it on my 52nd death instead of 50th.
                                Last edited: Nov 12, 2013
                              • Shimizu

                                Shimizu Orbital Explorer

                                Sometimes when you time stop an Ifrit will start sliding until the effect is over.

                                Also, don't know if its cause the items I had but killing 10 enemies with HAN-D's hammer didn't trigger.
                                • Matanui3

                                  Matanui3 Phantasmal Quasar

                                  I got Han-D's Kill 10 enemies achievement in multiplayer (as host) by killing one of the Ornate Wurms with it.
                                  However, my max multikill stat says 9.
                                  • meow247

                                    meow247 Pangalactic Porcupine

                                    what is this ornate wurm? never heard before. any pic?
                                    • jadkni

                                      jadkni Space Spelunker

                                      Very strange bug while playing a longer game as Acrid hunting for enemy logs.

                                      I became invisible and my movement was reduced to short, jerky stuttering on tapping the key repeatedly, my jump height was reset to the default speed, and my multiple proton packs stopped working. Resulted in me being unable to reach the console to summon Provi, which was a real shame.


                                      Included is the error log, which is a treat all its' own.

                                        Attached Files:

                                        Vizjun likes this.
                                      • Matanui3

                                        Matanui3 Phantasmal Quasar

                                        I think that's what the final boss worms are called.
                                        • TheTwlightZone

                                          TheTwlightZone Void-Bound Voyager

                                          Was running through with the Mercenary in the Ancient Temple (Monsoon difficulty) and got this error. Screen froze, then went black, but the game was still working. I could hear my character attack, but just a black screen.

                                            Attached Files:

                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page