1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Bug reports for Risk of Rain 1.0.2

Discussion in 'General Discussion' started by needsomemiracle, Nov 11, 2013.

Thread Status:
Not open for further replies.
  1. Mabui

    Mabui Void-Bound Voyager

    I play on a laptop wwith 1366x768 and the 4th bar is cut off except for the very top of items.
    The enitre 4th bar was full or 1-2 items away from full.

    This was 50 mins earlier. Most of the 4th bar where you can barely see the top of the item is over halfway.
    The screenshot bugged up for some reason and I'm too annoyed to care.

      Attached Files:

    • Burby

      Burby Phantasmal Quasar

      I also get a 4th bar from time to time, I believe the rows to display items are always the same length. I don't think that the times I got a 4th bar, I actually had enough unlocked to have even a remote chance for a 5th row.
      • Stickman1

        Stickman1 Phantasmal Quasar

        Deleting save files is baaaad. Somehow you managed to stop the player spawning. o_O
        • ShadowSlayer218

          ShadowSlayer218 Master Chief

          LOL, well I didnt do that at first, I played the game once, then that bug happened. I initially thought that it somehow got corrupted when I installed it, so I deleted it completely and re-installed it, played another game, died, but then it again wouldnt let me play a second game and that error would show up! So then I got frustrated, and just decided to delete the save files (cause why not), and it allowed me to play one more time, untill I died in which the error would come back -_____-
          • Hamst3rbot

            Hamst3rbot Aquatic Astronaut

            EDIT: DURR. Simply going back a page gave me my answer. Playing in drizzle is for the meek then, it seems, even though I got destroyed on the final level with a solid stack of teslas doing their job.

            Greetings, fellow Possibility of Precipitation players.:proper:
            My game is running absolutely stellar, but my problem is with the log files.

            There are no Monster or Item logs, the former not even having silhouettes.
            Under Scores and Challenges, only certain stats get updated under the "Stats" tab, eg. Damage Dealt, Multi Kill, Total Distance Ran, Total Gold Collected... But stats such as Total Time Played, Deaths, Boss Kills, Nemesis, Highest Level, Drone Count etc, stay a static 0, after 14 hours sunk into the game.
            Under General stats, the % played chart is displayed, but no stats show alongside.
            After quitting, all stats are wiped clean.

            The game itself is running fine. Unlocks, characters and achievements work without a problem, it's just the log files that aren't stored.
            And after reading a few other melancholic maladies here, deleting save files seem like a rather poor idea.
            What do? :(
              Last edited: Nov 27, 2013
            • aldrenean

              aldrenean Space Hobo

              I just thought I'd confirm the Chargefield Generator breaking when you pick up a second one, and add that picking up a third and more does not fix it. The bug report mentions the possibility of it only breaking if you pick up the second one while the first is active -- this does not matter: having more than one Chargefield Generator on a single character makes the whole stack useless.

              Sorry if this is redundant information, I've tried the search tool several times but it either isn't working properly or no one has ever mentioned Chargefield Generators in this forum lol.
              • Chthonic One

                Chthonic One Aquatic Astronaut

                I will third this bug. It does indeed stop working once you pick up a second. This also happens in multiplayer, though 2 players can have a single active at the same time, when one picks up a duplicate, both player's generator's break.
                  Duffie likes this.
                • wtchappell

                  wtchappell Space Hobo

                  Unlocking items while playing drizzle seems to save, though - so some progress is being saved, it seems. I can play drizzle and unlock items but I can't see what they do? Either progress should be saved in drizzle or it shouldn't be. How exactly is 'progress' defined?

                  EDIT: Unlocking new classes in drizzle is also saved.
                  • Treadlight

                    Treadlight Existential Complex

                    Character unlocks are saved in Drizzle for some reason, but nothing else should be. I heard that everything in Drizzle saves, but then you lose it next time you start up the game, also odd.
                    • Chthonic One

                      Chthonic One Aquatic Astronaut

                      Here we kinda broke your game, I'm sorry Hopoo. So much was going on I can't tell you what caused it or what contributed. Here's what was going on:
                      Meteor effect is going off, lots at once. Frame rate drops.
                      My spikeshoes goes off and stays on screen for some reason. Everything freezes except for players at this point. Even the explosions.
                      Friend had hit repair for his drones at this point as well.
                      Friend's drones start spawning like crazy. He has something like 1000 of them now.
                      I try to attack, and suddenly game fully breaks. We wait for a few minutes thinking it's going to crash. Then it moves again... slowly.

                      After this, I don't know what is going on, it's 1 frame per 3-15 seconds.
                      edit: Just an update. In an attempt to kill ourselves and end our misery, I activated my use item again. It nearly killed me, but not close enough. However it killed Kinam. Suddenly my frame rate returns to normal and he disconnects. I finished the game, and on my stats screen, it shows that my new max drone count was 633. :rofl:
                        Last edited: Nov 28, 2013
                      • Kinam

                        Kinam Intergalactic Tourist

                        ((I'm the other person in the linked highlight if it worked properly at least :D ))
                        So, after both of us killed our streams, we both were trying to die. The huge amount of lag was due to the sheer number of drones I had around me:
                        So yea... that was a LOT of drones. Eventually Chthonicone's meteor came up to use again, and I stood still, it eventually killed me, and once I died, he was able to move freely. Unfortunately the connection between our clients was so bogged down, that I was about a minute behind him LOL. While in the death animation I finally got disconnected from the game, and it didn't count the number of drones that I had while in that game. Funnily enough, after he finished the boss in no time at all, he looked on his stat page and the "highest drone count" was ..... 633 !!! NO WONDER THERE WAS LAG !!
                        • matthewshines

                          matthewshines Intergalactic Tourist

                          When you minimize the screen and scroll over where the box was it will make the sounds of scrolling over in game menu items, however I don't know if clicking activates anything.
                          • wtchappell

                            wtchappell Space Hobo

                            As far as I can tell, I have unlocked items in drizzle that stayed unlocked - and not just for that session, but permanently. What actually saves or doesn't save seems to be inconsistent with the statement that drizzle doesn't save progress. Either things should be more consistent, or the messaging around what playing in drizzle means needs to be cleaned up.
                            • Treadlight

                              Treadlight Existential Complex

                              The screen resolution shouldn't affect visibility, aside from how big the pixels can get.
                              • Aaryion

                                Aaryion Intergalactic Tourist

                                Hi guys,

                                Haven't seen a solution this this - when playing commando/muyltiplayer, suddenly, he stopped being able to move, except for stuttering. We werent even past level three. I have reinstalled, no luck. Rebooted, no luck. WTF.

                                  Attached Files:

                                • needsomemiracle

                                  needsomemiracle Scruffy Nerf-Herder

                                  1) Healing drone doesn't benefit from Arms Race, even though the item log says it applies to non-combat drones.

                                  2) It is possible to get two items from one weapon chest:
                                  Or, possibly, two weapon chests spawned in the corner on top of each other, which shouldn't happen either.

                                  3). Got an error log almost immediately after that:
                                  ERROR in
                                  action number 2
                                  of Alarm Event for alarm 0
                                  for object oClay:
                                  In script alarm_ai_default:
                                  In script teleport_nearby:
                                  Error in code at line 12:
                                          rety = tff.y+sprite_get_yoffset(ttele.sprite_index)-sprite_get_height(ttele.sprite_index)
                                  at position 48: Unknown variable sprite_index
                                  Here's where it happened:
                                    Last edited: Nov 28, 2013
                                  • andYz00m

                                    andYz00m Space Hobo

                                    Hello! New to the forum. Im really liking the game but I am running into an issue that is making me not want to play:

                                    Sometimes (might be first level might be 5th level), when I get into the portal to go to the next level, the client will hard crash. It just hangs there and it you click or do anything, the application not responding window comes up.

                                    I have tried a bunch of the trouble shooting tips from the OP but nothing is working for me. I tried re-installing VCredists (yes both), I am running as administrator, disabled Aero etc...

                                    Please help! I just played am amazing game only to have it crash after unlocking a ton of stuff. Cant play like this!!
                                      lations likes this.
                                    • meow247

                                      meow247 Pangalactic Porcupine

                                      if there's an error log post it here
                                      • DJFlare84

                                        DJFlare84 Spaceman Spiff

                                        I'm not sure if this is a bug or if the item description is simply not worded correctly.

                                        Playing Single Player as the Miner, and I found a Telescopic Sight. I've seen it work all of 2 times so far and both of those times IT MISSED.

                                        So, either there's something wrong with the item, or the description is wrong. It says "1% chance to instantly kill an enemy". Not only was it NOT instant (just nitpicking. I know, but...), it MISSED, so it wasn't even a guaranteed kill...
                                        • Avlaen

                                          Avlaen Aquatic Astronaut

                                          Hunter seems to have trouble unlocking (got 16 mnster logs huntress isnt playable)
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page