1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Bug list I've recently seen.

Discussion in 'General Discussion' started by e343balla, Apr 30, 2015.

  1. e343balla

    e343balla Big Damn Hero

    1. The ever famous "Fall though the map" glitch
    2. Players on Multiplayer (Me hosting) not being able to activate/pick up items and chests.
    3. General game crashes.
    4. End-Level dragon bosses "falling" off screen and vanishing, causing the need to restart the game.
    5. Ropes being lower/higher to the ground then they actually are.
    6. "Spite" Artifact location having open area in the top which allowed players to crawl around inside the map boundaries.

    Im probably forgetting some but these are the ones I'v noticed whilst playing the game.
    • buckyo

      buckyo Space Hobo

      The wonderful falling through the map... I was wondering, is the invisble platforms part of the game or a bug too? The fatal errors seem to happen the further/longer you play for. It seems to happen more since the last update. The last one i got was:
      Unable to find any instance for object index '204920'
      at gml_Object_oTurtle_Alarm_1
      • Allimon

        Allimon Void-Bound Voyager

        I believe Steam Achievements are also not unlocking properly - still.
          Xpyder likes this.
        • BikeHelmet

          BikeHelmet Orbital Explorer

          The netcode is broken, causing the game to desync between the host and other players.

          Magicka, Risk of Rain - some of my favourite games have terrible netcode!

          Though I can't really blame hopoo. I doubt gamemaker was intended to make stuff this complex.

          • kovec

            kovec Scruffy Nerf-Herder

            Yep, just got my last achievement, drown 20 whorls, in-game but it didn't unlock on Steam. Checked the forums on Steam and Reddit, it's a common problem since the last patch.
            • Jersey77

              Jersey77 Intergalactic Tourist

              Likewise just drowned my twentieth Whorl. Got the item unlock but no Steam achievement.

              Any devs know about this yet?
              • spyrodragon50

                spyrodragon50 Space Spelunker

                got 4 artifacts looped for one hour
                fuck this i am quiting[DOUBLEPOST=1433005404][/DOUBLEPOST]if the devs don't want to fix this
                more people will quit and rating will slowly went to negative from positive
                • Xpyder

                  Xpyder Seal Broken

                  The game is lovely, but i stopped playing since my steam achievements aren't unlocking... i've tried everything i could think about, including deleting everything redownloading and starting from the ground up(which was super boring...), tried enabling and disabling the cloud saves also... things aren't as fun without the steam achievements to show off so i won't be playing it again until this is fixed.
                    pvc likes this.
                  • ShadowlessWanderer

                    ShadowlessWanderer Pangalactic Porcupine

                    This could be desync (lag) OR caused by people using the explorer's key/skeleton key use item. There's a bug online with the explorer's key use item where if anyone EXCEPT the host uses it, chests open but the one who used it gets put into "money debt" and cannot interact with any command box/shrine/chest until they regain enough money to get out of the money debt. Basically it opens all chests on your screen (like it's meant to) but it still takes the money for all the chests (which is not meant to happen)

                    Simple solution is nonhost players don't use or pickup explorer's key.

                    And like Bikehelmet said, gamemaker wasn't meant for multiplayer games so the fact that it works at all with honestly not too many bugs is impressive.
                    • pvc

                      pvc Space Hobo

                      Experiencing the same problems. I'm also not going to recommend nor play the game untill it's solved!
                      • Oberic

                        Oberic Spaceman Spiff

                        Glitch 1 is really bothering me. I can't complete the first stage sometimes because I physically can't reach the teleporter. You say there are invisible platforms??
                        • linux_is_the_future

                          linux_is_the_future Space Hobo

                          I am using Linux and cannot get this game to work with my official xbox 360 controllers using the SteamOS xpad kernel module. The controllers register correctly with xpad and other games are able to utilize them without problems. Risk of Rain does not recognize them at all. This is sad because I think this game would be a great couch co-op SteamOS title. Unfortunately, it is very difficult to play local multiplayer without working controller support.
                          • Hemipheistos

                            Hemipheistos Orbital Explorer

                            :poke: 1. Ever famous falling thru map bug

                            I reinstalled the game after a long time break and wanted to finish my achievments.
                            Despite the fatal error stuff which i had to fix first, the bug Nr. 1 happened right after 2 min in the game, first stage.

                            Nope.. i do not wanna continue like this, seems a very frustrating setup. Pls, bring this game back to its glory. Thank you.

                            OS: Win 10 Professional 64 bit
                            GPU: Nvidia GTX970
                            CPU: AMD Phenom X6 II[DOUBLEPOST=1439647544][/DOUBLEPOST]
                            Are you kidding me.. Steam Achievment still bugged ?
                            • Infirito

                              Infirito Void-Bound Voyager

                              So, I've played RoR quite some time ago, that was fun, and decided to return to the game today... yeah, №1 got me right at the start. It's funny how the game was finished before and now it's not... Well, at least I don't lose sound in the menu anymore, right guys? :p

                              Share This Page