Modding Help Beginner's Guide to XNB Node and Graphics Editing

Discussion in 'Mods' started by cure, Mar 20, 2016.

  1. LiveWireGoth

    LiveWireGoth Void-Bound Voyager

    Sorry to bug you but for some reason when I tried to start up XNB Node it loads for a moment then closes for no reason, I even tried to re-downloading it but it happened again. Not even trying XNB Extract doesn't work. I have Windows 10(I had Windows 7 before but that was before having to get a new laptop) & I'm not sure if that's the problem or not. Sorry if I'm wasting someone's time or this was already asked or something.

    Nevermind found XNB Node Master & that works.>_>;
     
      Last edited: May 10, 2018
    • Entoarox

      Entoarox Oxygen Tank

      xnb-node is a console application, you need to open the console and run it through that, there should be instructions on *the google* you can follow.
       
      • LiveWireGoth

        LiveWireGoth Void-Bound Voyager

        Thanks for telling me
         
        • Blackblooddoomwolf

          Blackblooddoomwolf Void-Bound Voyager

          I'm a bit confused. I have multiple craftable.xnbs I'm trying to combine they try to replace each other when put together in a folder for extraction how can I stop this? If I rename them to stop them trying to replace each other will I just be able to change the name back to the original name to get it to work again?
           
          • Allayna

            Allayna Pangalactic Porcupine

            yep, just change names temporarily
             
            • Blackblooddoomwolf

              Blackblooddoomwolf Void-Bound Voyager

              Thank you so much! One more question I finished editing in gimp but now gimp has turned it into an xfb file. How do I change this back into a .png?
               
              • Allayna

                Allayna Pangalactic Porcupine

                you need to export it, not save it, it's wierd....
                and you want to uncheck the option for 'save background colors'
                 
                • Blackblooddoomwolf

                  Blackblooddoomwolf Void-Bound Voyager

                  Thanks for all the help! Everything seems to be in order!
                   
                  • ThatAnarchyDude

                    ThatAnarchyDude Aquatic Astronaut

                    I tried to pack an unpacked .tbin into a folder, and all I got was this:

                    C:\Program Files (x86)\Steam\SteamApps\common\Stardew Valley\Mods\Community\a
                    main.js:65
                    throw e;
                    ^

                    Error: EISDIR: illegal operation on a directory, open 'C:\Program Files (x86)
                    eam\SteamApps\common\Stardew Valley\Mods\Community\NewFarmMap'
                    at Error (native)
                    at Object.fs.openSync (fs.js:584:18)
                    at Object.fs.writeFileSync (fs.js:1224:33)
                    at packXnb (C:\Program Files (x86)\Steam\SteamApps\common\Stardew Valley\
                    s\Community\app\main.js:54:8)
                    at C:\Program Files (x86)\Steam\SteamApps\common\Stardew Valley\Mods\Comm
                    ty\app\main.js:60:16
                    at applyOrRecurse (C:\Program Files (x86)\Steam\SteamApps\common\Stardew
                    ley\Mods\Community\app\main.js:86:9)
                    at Command.<anonymous> (C:\Program Files (x86)\Steam\SteamApps\common\Sta
                    w Valley\Mods\Community\app\main.js:28:9)
                    at Command.listener (C:\Program Files (x86)\Steam\SteamApps\common\Starde
                    alley\Mods\Community\app\node_modules\commander\index.js:301:8)
                    at emitTwo (events.js:100:13)
                    at Command.emit (events.js:185:7)

                    C:\Program Files (x86)\Steam\SteamApps\common\Stardew Valley\Mods\Community>
                     

                    Share This Page