Modding Help back item - invisible :(

Discussion in 'Starbound Modding' started by Qbi Wan, Sep 6, 2017.

  1. Qbi Wan

    Qbi Wan Big Damn Hero

    Hi, I'm trying to make new back item. It's icon is OK, I can spawn it with commands. BUT I can't see it. I'm wearing it but no effect. Any ideas?

    [08:27:12.232] [Error] Could not load image asset '/hussarwings/back.png:idle.1', using placeholder default.
    (AssetException) No associated frames file found for image '/hussarwings/back.png' while resolving image frame '/hussarwings/back.png:idle.1'

     
  2. MetaFace

    MetaFace Guest

    Sounds like you're missing the frame file. You're gonna need a file in the same folder as the png with the same name, "back.frames".

    You should be able to easily use other item's frames file to give an example.
     
    Qbi Wan and bk3k like this.
  3. v6ooo

    v6ooo Cosmic Narwhal

    This is because you haven't placed it in the path /items/armors/******* and this way it doesn't use the default .frames

    Use anything but it must start in /items/armors/
     
    Last edited: Sep 6, 2017
    Qbi Wan and bk3k like this.
  4. projectmayhem

    projectmayhem Void-Bound Voyager

    I have all my back items in items/armors/backitems just like vanilla, and I still get the same error anytime I add a backitem. I always have to make a frame file
     
  5. v6ooo

    v6ooo Cosmic Narwhal

    It works like this if you make a file called back.png in /items/armors/whatever/path/
    it will look for a back.frames (or default.frames) in
    1. /items/armors/whatever/path/
    2. /items/armors/whatever/
    3. /items/armors/ (vanilla back.frames is here)
     
  6. Qbi Wan

    Qbi Wan Big Damn Hero

    I have added frame file and it works now.
    I'll try later to use defult ones :)
     
    MetaFace likes this.

Share This Page