1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Tool [All versions][Win/Linux] ModPackHelper

Discussion in 'Starbound Modding' started by Dolan, Feb 16, 2015.

  1. SpazDiesFirst360.0

    SpazDiesFirst360.0 Phantasmal Quasar

    Well, it's been an awful long time since I posted my status on packing and unpacking issues, but I made it work! I recommend a batch file structured like this:
    Code:
    "C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32\asset_packer.exe" "<location of mod EXACTLY>" "<location of where you want the pak file EXACTLY>"
    
    and save that as packmod.bat or whatever you want to name it, but include the .bat file type. Notepad can create batch files, so your okay to use that for making batch files.

    And, I don't know if anyone ever told you, but .modinfo files are out-of-date. Use .metadata or _metadata or the game won't read it.

    If that doesn't work, try copying the win32 folder and your mod to an external storage device and change the batch file paths respectively.
     
  2. JustJinxed

    JustJinxed Poptop Tamer

    You might want to add the ability in the asset_packer to utilize the new exclude via json option as well, or maybe allow the option to pass it through via "$@"?

    asset_packer -c <filename.json> <asset folder path> <output filename>
    The json file accepts all sorts of fun regex for globalIgnore and serverIgnore. While serverIgnore is less used, many people place source file images from gimp or their favorite editors, in the same directory as their release png files to keep things easy to edit. There's also an order directive, but I'm not sure it's useful in the current builds of SB.

    filename.json common format example:

    Code:
        "globalIgnore": [
            ".work",
            ".*\\.xcf.*"
            ],
        "serverIgnore": [
            ".spatch",
            "*.c"
            ]
    }
    
     
  3. Luxuriatic

    Luxuriatic Space Hobo

    it just keeps crashing whenever i choose an option
     
  4. Zombiexeffect

    Zombiexeffect Void-Bound Voyager

    I tried .11 and .10 and it just closes without doing anything when its run in the real game folder, when I copy the asset file to another folder on the desktop it tries to tell me its successfully unpacked but to the _Unpacked folder which does not exist... same thing happens when run with admin privs
     
    alicedafox likes this.
  5. Qbi Wan

    Qbi Wan Pangalactic Porcupine

    It's broken. Generally packing is broken here. Every time get back to modding i spend few days trying to make it working. What are freetype6.dll or cygvorbisfile-3.dll? Why do I need them all of a sudden????!??!?!!? how to use asset_unpacker.exe? Non of tips nor from starbounder or this forum are working
     
    DaIIas likes this.
  6. YunhoTheStarbounder

    YunhoTheStarbounder Aquatic Astronaut

    When I use the other options they work fine, but when I want to unpack the assets they don't work. Help!
     
    Last edited: Apr 26, 2018
  7. Catherine Franz

    Catherine Franz Scruffy Nerf-Herder

    Guess this is still not fixed,bummer... (was about to try and make one)

    EDIT:Nvm just use the 10th .bat file and that should work fine...(time to fry my brain..my young brain..)
     
    Last edited: Sep 18, 2018
  8. JakerH2

    JakerH2 Space Hobo

    i cannot get this to work

    it just says that it cant find the assets file .-.
     
  9. Talon Gaming

    Talon Gaming Tentacle Wrangler

    It isn't working for me. I have the .bat file in the "assets" folder under Starbound, and it opens just fine, but when I type in 0 to unpack the assets and hit enter, the window just closes. It seems to say something, but it closes too fast for me to read it. Help? Anyone?
     
  10. Talon Gaming

    Talon Gaming Tentacle Wrangler

    Update: the same thing happens when I try to unpack mods. I hit two, then enter, and that works right, but whether I choose 0 or 1 for the next choice, it crashes. Again, it says something, but I can't read that fast.
     

Share This Page