Achievements Not Unlocking On Steam Fix

Discussion in 'Mods' started by jakenastysnake, Apr 4, 2016.

  1. jakenastysnake

    jakenastysnake Void-Bound Voyager

    Hey guys! So I was having this problem, where for whatever reason the achievements would unlock IN-GAME, but they were not unlocking in Steam.

    Well, I found out how to fix these. Figured I'd post this in the forums so if anybody else is having this problem they can fix it themselves. I know how frustrating it can be to complete an achievement only to have it not unlock!

    Step 1:
    The first step is to locate your save file and MAKE A BACKUP! Save file can be found at C:\Users\(Your Username)\AppData\Roaming\StardewValley\Saves. You should find a folder with 2 files, your main save file (looks like User_123456789) and SaveGameInfo.

    *Note - If you can't see the AppData folder, you may need to go into Control Panel and select Folder Options, select the View tab, and select Show hidden files, folders, and drives

    Step 2:
    Next step is to open your main save file in Notepad++. You can get it from

    With both your save file and the SaveGameInfo file opened in Notepad++, search your main save file for "achievements" by clicking on Search --> Find... and type in achievements

    You should come to a section of the XML code with 2 tags <achievements></achievements>. Now between these tags should be all of the achievements that you have unlocked in the game. Delete everything between these 2 tags and save the changes. Others have stated that you need to make the changes in BOTH files, but just changing them in my main save file worked fine. It's probably a good rule of thumb to make the same changes in BOTH files if possible


    Step 3:
    The last step is to run Stardew Valley and load up your game. Depending on what achievement is giving you trouble, you will have to complete it again. In other words, if the achievement "A New Friend" is not unlocking for you, just go ahead and give the friend another gift. If you've done all this correctly, the achievement should pop again in-game AND on Steam. If the "D.I.Y" achievement isn't unlocking, simply craft another item or 2 until the achievement pops etc.

    Step 4:
    After you make sure the achievement has unlocked in-game AND in Steam, close Stardew Valley and go ahead and replace your save files with the backups you made. This just makes sure that everything is exactly how you left it before you started editing any files.

    This is basically all you have to do to get the achievements to unlock if they are not unlocking for you. Some achievements require a bit more work, such as the "Moving Up" achievement.

    What I had to do for the "Moving Up" achievement was go into BOTH save files and delete all the achievements first like in step 2. Then I had to search the MAIN file for "Farmhouse". In this section, you should find a tag called <upgradeLevel>1</upgradeLevel>. I had to change this from 1 to 0.

    Then I had to search BOTH files for "houseupgradelevel" and "daysuntilhouseupgrade". Change <houseupgradelevel>1</houseupgradelevel> to 0 and change <daysuntilhouseupgrade>-1</daysuntilhouseupgrade> to 1.

    After making these changes and starting the game, you should just be able to go to sleep and the achievement will pop when it checks for the conditions.

    I hope this helps somebody who might be having the same problem. If you have any questions feel free to ask and I'll do my best to help you out.
      Last edited: Apr 4, 2016
    • taintedwheat

      taintedwheat Master Astronaut

      Must be sporatic then because I just have the smapi api (and when I was using storm) run through steam by changing the directory from just the vanilla program to where the modding program is located in the folder near the game itself.

      It reads any unlocked achievement fine

      Is it set up for you like that?
      • jakenastysnake

        jakenastysnake Void-Bound Voyager

        Actually I don't use any mods, this is just the standard version of the game (latest update on Steam). I may have posted this in the wrong place, my bad lol.
        • taintedwheat

          taintedwheat Master Astronaut

          Oh wow, dang! Im sorry you have to do all of that then ):
          • jakenastysnake

            jakenastysnake Void-Bound Voyager

            Haha it's all good now I got it sorted. Don't know why some of them just decided to not unlock on Steam though, strange.
            • Artlan

              Artlan Scruffy Nerf-Herder

              This is great for folks like me who didn't have steam setup to handle the API loader initially. Was able to get all of my achievements back! Thanks a bunch :D
                jakenastysnake and taintedwheat like this.
              • jakenastysnake

                jakenastysnake Void-Bound Voyager

                Awesome dude! Glad it helped you out!
                • zappaslave

                  zappaslave Void-Bound Voyager

                  So how do we make the achievements pop IN game. I've run into an issue where I have donated all item, and have found all items (artifacts AND minerals). I checked them all off, I have 95/95 and I didn't get an achievement ping either in game or steam.
                  • missriz

                    missriz Big Damn Hero

                    I was wondering why I couldn't get the millionaire achievement (when i already earned almost 2mil). Apparently, mine was not unlocking. This really helped me.Thanks!
                    • hunkadory

                      hunkadory Space Hobo

                      I did this and I actually managed to get 3 steam achievements I have been waiting for, however there is still two achievements that I couldn't get to trigger (Monster slayer thing and getting lvl 10 in all skills) I have done both of them in game, but I can't get the achievements for them by doing things related to them like I did to get master chef (cooking anything) etc. Any advice?
                        Last edited: Feb 6, 2017
                      • Haxry

                        Haxry Space Hobo

                        Hi! I've tried this as all the ways I could and it didn't worked on me, or the game crashes, or there are only 6 achievements locked that I already have in my backup save. Also I have problems with item tracking, I have picked and I have in my inventory items that didn't got checked on my pool, for example, any ingot, I got all them and the game still thinks that I have never seen them. Any idea to how can I solve it? D:
                        • Draelan

                          Draelan Intergalactic Tourist

                          Sorry if this is reviving an older thread, but I found this via Google when looking for ways to fix my missing achievements on Steam and, while this was quite helpful, I wanted to add a few more details for the trickier achievements to fix. Specifically, I'm talking about "Master of the Five Ways" (Getting all skills to max) and "Protector of the Valley" (Completing the guild monster slaying goals) since these two require a bit more editing than just deleting the in-game achievements.

                          For "Master of the Five Ways" I artificially lowered my combat skill so I could re-earn level 10. (I chose combat since I needed Protector of the Valley as well, but you can lower any of the five skills.)
                          If you open up your save file like the OP suggested and search for "experiencePoints" you will find six integers between <experiencePoints></experiencePoints>. These are for the five skills and Luck. Now, they're not labeled which int is for which skill, (with Luck being the only obvious one at 0 experience points since there's no way to gain exp for it.) so you can just go ahead and set all of them to 14999. This will put each skill at 1 exp below level-up to reach level 10. (The game doesn't seem to bother checking if you're already at level 10, so there's no harm in it.)
                          That alone won't change anything. There is one other parameter you need to change for this achievement. Do a search for "combatLevel" and you'll find the levels for each of your skills. You'll want to change combatLevel to 9.
                          Once those changes are made, all you need to do is open up the game and kill one enemy to re-gain that level and, next time you have your character sleep you should gain the achievement.

                          For "Protector of the Valley" I also altered two things.
                          First, search for "Skeleton" and scroll to the right a bit. The first number you encounter after that should be the number of Skeletons you've killed. (I chose Skeletons since there's only 1 type of enemy that counts for this and they're very common on their floors. It'll also work fine with Duggys or Dust Spirits.) You need to kill 50 skeletons for the guild, so set this number to 49.
                          Secondly, just to be sure it will trigger, search for "Gil_Skeleton Mask" and delete the string associated with it. (Including the <string></string> around it.) That should mean the game thinks you haven't earned that reward yet.
                          Then you just save, load up the game, and kill a skeleton. You should get the achievement right away.

                          I hope this helps anyone else who stumbles across this thread like I did with gaining their rightfully-earned achievements. It's a bit frustrating when you realize that you didn't get credit, especially when you don't have any mods for the game so you know it isn't your fault. At least that's the worst thing I can say about this game. Well, that and it's eaten up so many hours of my life, haha! Now, if you'll excuse me, I have a farm to tend to. :)
                            Ari Rashkae likes this.
                          • Toast435

                            Toast435 Void-Bound Voyager

                            I need a little help with the last achievement for me.
                            It's "A Big Help" and I've done everything listed up above, however it's only unlocking in Stardew Valley and not on Steam.
                            It's literally the last achievement I need and it's driving me crazy since I don't have it.
                            I use SMAPI for cosmetic mods, spawning in items, and running faster; SMAPI hasn't caused any problems for me in the past and I've gotten almost all of my achievements with the program running.
                            I'm not sure what to do and any help would be appreciated.
                            • Shekelo

                              Shekelo Space Hobo

                              A mí me funcionó!
                              Muchas Gracias!
                              • GiGio

                                GiGio Space Hobo

                                When I changed the User_123456789 file, i couldn't load my game. It always threw me back to the intro.
                                After that I changed only the SaveGameInfo it told me it couldn't find a game
                                so..still no achievments for me :c
                                • macaro0n

                                  macaro0n Void-Bound Voyager

                                  Same, it doesnt work for me too. I've reached 10 hearts of a villager and it doesnt trigger any achievement.
                                  Oh well :'D

                                  RIP, OP doesnt reply anymore.
                                    Last edited: Jul 23, 2018
                                  • Pizzaia93

                                    Pizzaia93 Space Hobo

                                    It works 4 me, thanks a lot!
                                    • localheroines

                                      localheroines Aquatic Astronaut

                                      Hi, 3 years late on this question, but I'm desperate- does anyone know the exact code to help retrigger the "Polyculture" achievement (shipping 15 of every crop)? I have it in-game but was offline when it triggered. I've done some digging around in my file, but I'm just not sure what to change in order to retrigger it. Any help would be greatly appreciated!

                                      Share This Page