1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Closed Access violation error: Can't play game! :(

Discussion in 'Starbound Support' started by DrBob3002, Dec 4, 2013.

Thread Status:
Not open for further replies.
  1. Tatsuran

    Tatsuran Intergalactic Tourist

    Same error, win 7 x64.


    [​IMG]
    [​IMG]

    "Run as admin" or UAC enabled - don't work for me.
    More fun:
    1. check "run as admin" in properties of launcher.exe, starbound.exe, starbound_opengl.exe, Steam.exe
    2. close steam
    3. run launcher
    4. press "Launch Starbound"
    5. get the game running! Steam starts and... launches one more launcher
    6. press "Launch Starbound" in second launcher
    7. get "access violation"
    8. search for support
     
  2. pal_slide

    pal_slide Space Hobo

    Hi there! I managed to solve this problem on my win XP 32bit by replacing file sdl.dll in win32 folder of the game.
    Here's the link. http://speedy.sh/wqNBm/SDL.dll
     
    Change likes this.
  3. lillmonkey

    lillmonkey Space Hobo

    Wait my game opens with Linux 32 does that have something to do with it?
     
  4. Samogon

    Samogon Void-Bound Voyager

    Same problem. Solutions not helped. 8.1 64
     
  5. uldupits

    uldupits Orbital Explorer

    If anyone tries this than be sure to have a backup.... Messed my game up even more!
     
  6. Hippy Druid

    Hippy Druid Aquatic Astronaut

    Yep, tried it all, nothing works!! Win7 64bit

    What is strange, is, the above-mentioned method did work for me until the update. Now all I get is the access violation error..

    I have completely deleted and re-installed Starbound twice now. Same old crud!

    :(
     
  7. uldupits

    uldupits Orbital Explorer

    Well it seems like most people would say its some problem with our RAM..
     
  8. am1sf1t

    am1sf1t Void-Bound Voyager

    The game has been running fine for me on Windows 7 64-bit, but I tried to run the multiplayer server after the patch and I experienced the access violation error every time I tried to run it.

    After trying nearly all the solutions suggested in this thread, none of which made a difference, I found another thread mentioning disabling UPnP Port Forwarding in the starbound.config file located in the main Starbound game folder. Once I changed the default "True" setting to "False" the server runs fine without the access violation error popping up. I hope this helps someone out there. :)
     
  9. Change

    Change Orbital Explorer

    Worked Its NOT works anymore
     
    Last edited: Dec 13, 2013
  10. Hiddeneagle

    Hiddeneagle Void-Bound Voyager

    Everytime i try run Starbound i get this stupid access violation error :/
    If anyone has any usfull idea's, i would really be happy to hear it :(
     
  11. ALERT

    ALERT Yeah, You!

    win7\win8 solution, anyone?
     
  12. BenevolentManiac

    BenevolentManiac Space Spelunker

    I had this problem after my dedicated server (Server 2008r2) shut down uncleanly (power loss). Files in the 'Universe' folder under the game's root directory had become damaged since they were being accessed at the time of the power failure. The easiest thing to do in this case is to just remove your Universe folder (it gets recreated once you start the game again). This, of coarse, generates an entire new Universe, but I was able to copy all the .world files from my original Universe folder into the new Universe folder, restoring all the worlds I'd been to. Started the game back up with no problems! This folder seriously needs a periodic backup file created every 10 minutes or so. Since the .world files didn't seem to be the problem, I'm assuming it has to do with either the .DAT file or the database files... in any case, hope this works for ya!
     
  13. BenevolentManiac

    BenevolentManiac Space Spelunker

    Quick Update on this: Also need to copy the .clientcontext files from the old "universe" folder - these maintain the players' current location in the Universe as well as their access in the universe (ie. Alpha, Beta, Gamma systems). Otherwise, you'll have to get all the tech upgrades again.
     
  14. InvalidToken

    InvalidToken Yeah, You!

    Try ignoring the errors and waiting for the game to load, it worked for me.
     
  15. uldupits

    uldupits Orbital Explorer

    press "x" or just dont touch them?
     
  16. InvalidToken

    InvalidToken Yeah, You!

    Just don't touch them.
     
  17. StarHusky

    StarHusky Space Hobo

    Untitled.png Untitled.png This is my issue with Access Violation

    Start the game > gets to the character screen > choose character and enter ship > open the first panal on the ship to get the material manipulator > touch any item in the box game crashes with violation error


    aaaaaanny ideas?
     
    Last edited: Dec 9, 2013
    jimis likes this.
  18. SurfingBrah

    SurfingBrah Space Hobo

    For all thoes that have Windows 8, you need to upgrade to 8.1 for it to work. It worked for me and now i am playing the game with great frames and no issues
     
  19. Tatsuran

    Tatsuran Intergalactic Tourist

    Patch fixed nothing. A good way - to deliver content patches instead of fixing blockers.
     
  20. Tatsuran

    Tatsuran Intergalactic Tourist

    tried steam beta - still crashes
     
Thread Status:
Not open for further replies.

Share This Page