Modding Help Unpacking a pak mod

Discussion in 'Starbound Modding' started by NeoslayerX, Aug 8, 2016.

  1. NeoslayerX

    NeoslayerX Star Wrangler

    I figured out how to unpack via CMD, but it doesn't work with mods that come in the pak format..

    How do I unpack them without getting this ERROR

    C:\Program Files (x86)\Steam\steamapps\common\Starbound>"win32\asset_unpacker.exe" "assets\AnTiMonster.pak" "CrazyAssets"
    Error: Automatic close of SimpleDatabase 'assets\AnTiMonster.pak' in destructor failed! (IOException) write called on non-writable File
    [0] b240ba
    [1] b20a48
    [2] b4ccf2
    [3] b37144
    [4] b51191
    [5] b4eef8
    [6] b4ec13
    [7] b3fa20
    [8] b3803e
    [9] b81da7
    [10] b11c49
    [11] b7c5b9
    [12] 748938f4 BaseThreadInitThunk
    [13] 77b85de3 RtlUnicodeStringToInteger
    [14] 77b85dae RtlUnicodeStringToInteger


    I tried unpacking Frackin, AnTiMonster, and anime eyes, but they all have the same respective error.

    I just want those mods to work.. I'm losing all hope..
    (Read my recent posts if you care about why I'm losing hope)
     
    Last edited: Aug 8, 2016
  2. leinglo

    leinglo Phantasmal Quasar

    You don't have to unpack a .pak mod to make it work, you just put it in the mod folder and you're done. You only have to unpack it if you want to fiddle around with the assets.

    In that case, you just follow this:
    “Location of Unpacker” “Location of pak file” “Location to unpack”
    Example:
    "C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32\asset_unpacker.exe" "C:\Program Files (x86)\Steam\steamapps\common\Starbound\assets\packed.pak" "C:\Program Files (x86)\Steam\steamapps\common\Starbound\unpacked"
    In either CMD or as a text executable, and if it doesn't work, there's something you just didn't enter in quite right. Personally, I'd recommend the text executable for it rather than CMD

    Either way, there's more detailed instructions on that here and here. The latter video tutorial details the text executable method.
     
  3. NeoslayerX

    NeoslayerX Star Wrangler

    That's what I'm trying to say. I tried that and I get the error in the spoiler.
    :facepalm::facepalm::facepalm:
     
  4. Mioure

    Mioure Scruffy Nerf-Herder

    You have to edit the Unpacker batch using notepad++ to your location of the .pak and then a new folder

    @Echo off
    echo Unpacking ..\FrakinUnpak\FrackinUniverse.pak into ..\FrakinUnpak\unpacked\
    echo This may take a long time.
    start /wait /min .\asset_unpacker.exe ..\FrakinUnpak\FrackinUniverse.pak ..\FrakinUnpak\unpacked
    echo Done.
    pause

    I believe they have to be in the same folder, or same directory. This is what I did for mine and it worked.
    Make sure when you move the unpacker, you move both the "unpack_assets.batch" and "assets_unpacker.exe" as they don't work without each other.
     
  5. NeoslayerX

    NeoslayerX Star Wrangler

    Dumb that down for me. What was that.
    :speechless:
     
  6. Mioure

    Mioure Scruffy Nerf-Herder

    Sorry for late reply.

    You should have two files in your Win32 folder for Starbound.
    assets_unpacker.exe and unpack_assets.batch
    AssetsImage.png

    Copy these two files into the folder you want to unpack, In this case Frackin' Universe.

    Right-click the unpack_assets.batch and edit with Notepad++
    If you don't have an unpack_assets.batch then create a new file using Notepad++ and insert the following:

    @Echo off
    echo Unpacking ..[Folder directory of the Pak /Pak File Itself] into ..[Folder directory you want to unpack into]
    echo This may take a long time.
    start /wait /min .\asset_unpacker.exe ..[Folder directory of the Pak /Pak File Itself] ..[Folder directory you want to unpack into]
    echo Done.
    pause

    For the [Folder directory of the Pak /Pak File Itself] you want to enter the folder from the address of where the pak is located, like so: (You only need the main folder its in)

    ../FrackinUniverse/FrackinUniverse.pak

    for the [Folder directory you want to unpack into], use the same folder as above, but add Unpacked as a new folder like so:

    ../FrackinUniverse/Unpacked

    So it should look like this

    @Echo off
    echo Unpacking ..\FrackinUniverse\FrackinUniverse.pak into ..\FrackinUniverse\Unpacked\
    echo This may take a long time.
    start /wait /min .\asset_unpacker.exe ..\FrackinUniverse\FrackinUniverse.pak ..\FrackinUniverse\Unpacked
    echo Done.
    pause

    Afterwards, just double-click the unpack_assets.batch file and it should work.
     

    Attached Files:

  7. Myth67

    Myth67 Space Spelunker

    So thats how to use it.
    Thanks im also making this file to help me with unpacking and packing.
     

    Attached Files:

  8. CatofRiddles

    CatofRiddles Astral Cartographer

    I'm still getting the same error. is this outdated, or does it still work?
     

Share This Page