1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/
  2. Hey Guest! We've announced our new game Wargroove, check out the new forums!
    Dismiss Notice

Multiple Graphics Card Crash

Discussion in 'Support' started by niqdisaster, Sep 8, 2016.

  1. niqdisaster

    niqdisaster Space Hobo

    Hello I am running 2 graphics cards in my laptop and the game crashes when im using my nvidia but doesn't when I use the integrated card (which is garbage) what do I need to do to make it so that the game is cooperating with the nvidia card?
     
  2. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    I am also getting this. Launching the game results in either a solid black window, or a solid black window with a smaller white window. In my case the game does not crash, however it does not start. I've left it that way for upwards of 10 minutes with no change. The music plays but that's it.

    Same behavior on x86 and x64. Same behavior on Unsable vs. Vanilla. Some things I tried that didn't work at all (and were suggested in other forums):
    • Reinstalling directx
    • Reinstalling all the VC++ redistributables that I had on my machine, including those shipped directly with the game
    • Reinstalling the game via steam
    • launching the game from outside of steam
    • launching the game with/without various windows compat options turned on (admin, win8, highdpi, etc)
    • Updating the the latest version of windows available
    • Ensuring my graphics card drivers were up to date
    • Grabbing all of the UI dlls from C:\Program Files (x86)\Windows Kits\10\Redist\ucrt\DLLs and copying them locally into the game folder
    • Renaming the 32 bit folder to the 64 bit folder and trying again
    I was also unable to find any rundown of the launch options that I may use to pick different rendering modes or anything like that. If someone could send that along that would be great.

    Attached the most boring screenshot ever of a white box on top of a black box and dxdiag. I am also attaching the game log from when the game doesn't work and when it does work (once I go and manually force the game to use the integrated graphics card, which sucks). Although the game does launch with the specific integrated card, it is basically unplayable (bad frame tears and FPS, requiring much lower resolution play to be feasible).

    I would upload my game config file, but that's apparently not allowed (may want to think about allowing that) so instead I paste the whole thing below, just in case that helps.

    It's worth noting that I found the solution in this forum. However it doesn't work if I ever set it back to the main graphics card, no matter what I try. It will only play with the integrated graphics. Even if I launch, adjust settings, and then change back to the main card, things remain broken. I can continue to try to find a particular setting or control to disable in the main graphics card that would make the game playable, however this is a real needle in a haystack without any guidance from the authors.



    {
    "allowAdminCommands" : true,
    "allowAdminCommandsFromAnyone" : false,
    "allowAnonymousConnections" : true,
    "allowAssetsMismatch" : false,
    "anonymousConnectionsAreAdmin" : false,
    "audioChannelSeparation" : [-25, 25],
    "bannedIPs" : [],
    "bannedUuids" : [],
    "bindings" : {
    "CameraShift" : [{
    "mods" : [],
    "type" : "key",
    "value" : "RCtrl"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "LCtrl"
    }],
    "ChatBegin" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Return"
    }],
    "ChatBeginCommand" : [{
    "mods" : [],
    "type" : "key",
    "value" : "/"
    }],
    "ChatNextLine" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Down"
    }],
    "ChatPageDown" : [{
    "mods" : [],
    "type" : "key",
    "value" : "PageDown"
    }],
    "ChatPageUp" : [{
    "mods" : [],
    "type" : "key",
    "value" : "PageUp"
    }],
    "ChatPreviousLine" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Up"
    }],
    "ChatSendLine" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Return"
    }],
    "ChatStop" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Esc"
    }],
    "CinematicNext" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Right"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "Return"
    }],
    "CinematicSkip" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Esc"
    }],
    "CockpitDown" : [{
    "mods" : [],
    "type" : "key",
    "value" : "S"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "Down"
    }],
    "CockpitLeft" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Left"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "A"
    }],
    "CockpitRight" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Right"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "D"
    }],
    "CockpitUp" : [{
    "mods" : [],
    "type" : "key",
    "value" : "W"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "Up"
    }],
    "EmoteAnnoyed" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Right"
    }],
    "EmoteBlabbering" : [{
    "mods" : ["LCtrl", "LShift"],
    "type" : "key",
    "value" : "Right"
    }],
    "EmoteBlink" : [{
    "mods" : ["LCtrl"],
    "type" : "key",
    "value" : "Up"
    }],
    "EmoteEat" : [{
    "mods" : ["LCtrl", "LShift"],
    "type" : "key",
    "value" : "Down"
    }],
    "EmoteHappy" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Up"
    }],
    "EmoteLaugh" : [{
    "mods" : ["LCtrl"],
    "type" : "key",
    "value" : "Left"
    }],
    "EmoteNeutral" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Left"
    }],
    "EmoteOh" : [{
    "mods" : ["LCtrl"],
    "type" : "key",
    "value" : "Right"
    }],
    "EmoteOooh" : [{
    "mods" : ["LCtrl"],
    "type" : "key",
    "value" : "Down"
    }],
    "EmoteSad" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Down"
    }],
    "EmoteShouting" : [{
    "mods" : ["LCtrl", "LAlt"],
    "type" : "key",
    "value" : "Up"
    }],
    "EmoteSleep" : [{
    "mods" : ["LCtrl", "LShift"],
    "type" : "key",
    "value" : "Left"
    }],
    "EmoteWink" : [{
    "mods" : ["LCtrl", "LShift"],
    "type" : "key",
    "value" : "Up"
    }],
    "EssentialBar1" : [{
    "mods" : [],
    "type" : "key",
    "value" : "R"
    }],
    "EssentialBar2" : [{
    "mods" : [],
    "type" : "key",
    "value" : "T"
    }],
    "EssentialBar3" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Y"
    }],
    "EssentialBar4" : [{
    "mods" : [],
    "type" : "key",
    "value" : "N"
    }],
    "GuiClose" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Esc"
    }],
    "GuiShifting" : [{
    "mods" : [],
    "type" : "key",
    "value" : "RShift"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "LShift"
    }],
    "InterfaceBar1" : [{
    "mods" : [],
    "type" : "key",
    "value" : "1"
    }],
    "InterfaceBar10" : [],
    "InterfaceBar2" : [{
    "mods" : [],
    "type" : "key",
    "value" : "2"
    }],
    "InterfaceBar3" : [{
    "mods" : [],
    "type" : "key",
    "value" : "3"
    }],
    "InterfaceBar4" : [{
    "mods" : [],
    "type" : "key",
    "value" : "4"
    }],
    "InterfaceBar5" : [{
    "mods" : [],
    "type" : "key",
    "value" : "5"
    }],
    "InterfaceBar6" : [{
    "mods" : [],
    "type" : "key",
    "value" : "6"
    }],
    "InterfaceBar7" : [],
    "InterfaceBar8" : [],
    "InterfaceBar9" : [],
    "InterfaceChangeBarGroup" : [{
    "mods" : [],
    "type" : "key",
    "value" : "X"
    }],
    "InterfaceCodex" : [{
    "mods" : [],
    "type" : "key",
    "value" : "L"
    }],
    "InterfaceCrafting" : [{
    "mods" : [],
    "type" : "key",
    "value" : "C"
    }],
    "InterfaceDeselectHands" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Z"
    }],
    "InterfaceEscapeMenu" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Esc"
    }],
    "InterfaceHideHud" : [{
    "mods" : ["LAlt"],
    "type" : "key",
    "value" : "Z"
    }],
    "InterfaceInventory" : [{
    "mods" : [],
    "type" : "key",
    "value" : "I"
    }],
    "InterfaceQuest" : [{
    "mods" : [],
    "type" : "key",
    "value" : "J"
    }],
    "InterfaceReload" : [{
    "mods" : [],
    "type" : "key",
    "value" : "F8"
    }],
    "InterfaceRepeatCommand" : [{
    "mods" : [],
    "type" : "key",
    "value" : "P"
    }],
    "InterfaceToggleFullscreen" : [{
    "mods" : [],
    "type" : "key",
    "value" : "F11"
    }],
    "KeybindingCancel" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Esc"
    }],
    "KeybindingClear" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Del"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "Backspace"
    }],
    "PlayerDown" : [{
    "mods" : [],
    "type" : "key",
    "value" : "S"
    }],
    "PlayerDropItem" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Q"
    }],
    "PlayerInteract" : [{
    "mods" : [],
    "type" : "key",
    "value" : "E"
    }],
    "PlayerJump" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Space"
    }],
    "PlayerLeft" : [{
    "mods" : [],
    "type" : "key",
    "value" : "A"
    }],
    "PlayerRight" : [{
    "mods" : [],
    "type" : "key",
    "value" : "D"
    }],
    "PlayerShifting" : [{
    "mods" : [],
    "type" : "key",
    "value" : "RShift"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "LShift"
    }],
    "PlayerTechAction1" : [{
    "mods" : [],
    "type" : "key",
    "value" : "F"
    }],
    "PlayerTechAction2" : [],
    "PlayerTechAction3" : [],
    "PlayerUp" : [{
    "mods" : [],
    "type" : "key",
    "value" : "W"
    }],
    "ShowLabels" : [{
    "mods" : [],
    "type" : "key",
    "value" : "RAlt"
    }, {
    "mods" : [],
    "type" : "key",
    "value" : "LAlt"
    }],
    "TitleBack" : [{
    "mods" : [],
    "type" : "key",
    "value" : "Esc"
    }]
    },
    "borderless" : false,
    "checkAssetsDigest" : false,
    "clearPlayerFiles" : false,
    "clearUniverseFiles" : false,
    "clientIPJoinable" : true,
    "clientP2PJoinable" : true,
    "configurationVersion" : {
    "basic" : 1,
    "client" : 6
    },
    "crafting" : {
    "filterHaveMaterials" : false
    },
    "fullscreen" : true,
    "fullscreenResolution" : [1920, 1080],
    "gameServerBind" : "*",
    "gameServerPort" : 21025,
    "interactiveHighlight" : true,
    "inventory" : {
    "pickupToActionBar" : true
    },
    "limitTextureAtlasSize" : false,
    "maxPlayers" : 8,
    "maxTeamSize" : 4,
    "maximized" : true,
    "musicVol" : 70,
    "playerBackupFileCount" : 3,
    "queryServerBind" : "*",
    "rconServerBind" : "*",
    "renderSleep" : true,
    "safeScripts" : true,
    "scriptInstructionLimit" : 10000000,
    "scriptInstructionMeasureInterval" : 10000,
    "scriptProfilingEnabled" : false,
    "scriptRecursionLimit" : 100,
    "serverFidelity" : "automatic",
    "serverName" : "A Starbound Server",
    "serverUsers" : {
    },
    "sfxVol" : 100,
    "speechBubbles" : true,
    "title" : {
    "multiPlayerAccount" : "",
    "multiPlayerAddress" : "",
    "multiPlayerPort" : ""
    },
    "tutorialMessages" : true,
    "vsync" : true,
    "windowedResolution" : [1920, 1080],
    "zoomLevel" : 3
    }

     

    Attached Files:

    Last edited: Feb 20, 2017
  3. Megumin

    Megumin Guest

    try to launch all 4 cores via msconfig
    click on Windows icon+R then enter click on "Boot" then "Advanced"
    "Number of Processors" if you have 4 change it to 4
    (notice: if it will ask reboot your pc/laptop do so)
    way 2: if it says "No suitable Graphics cards found" try to delete Starbound.config in game folder
    way 3: open Starbound.config and disable vsync (example vsync: false)

    please for long text use spoiler code
     
    Last edited by a moderator: Feb 16, 2017
  4. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    Sorry to be such a nub. Please show instructions for how to do so. I hovered over all the widgets and didn't see an option.
     
  5. Megumin

    Megumin Guest

    [spoiler with another thing (to close it use [/spoiler ) for example <spoiler>text</spoiler> replace <> on []
     
  6. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    Editing the cores per the startup boot options had no effect. Proceeding to other options. (edit, updated spoiler text, so that's trimmed down at least)
     
  7. Megumin

    Megumin Guest

    it was helpful for me, not sure if it was for others
     
  8. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    I do not receive this message, let me know if I should still try.

    No effect.
     
  9. Megumin

    Megumin Guest

    looks like thing with config was helpful i guess?
     
  10. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    No, nothing has changed yet. It still doesn't work even with all these changes applied unless the internal graphics card is forced to be the one Starbound uses.
     
  11. Hel

    Hel NERV This!! Forum Moderator

    please edit posts to avoid double posting.

    @JohnnyRandomWalker you should have made your own topic instead of hijacking one from September. I'll let you off this time, but please do not do it again
     
  12. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    I edited it.


    Yeah sounds great. Too kind. If I can't get it working I'm unlikely to have many more posts or questions anyway :( In the meantime I thought it might be useful to others to have a bunch of info in the same place rather than spread about.

    So is this just entirely community driven or do the real devs check in once in a while? And if the error has been going on for multiple users (found all sorts of random reports for this issue on Steam and other forums) shouldn't it be getting at least a little more attention?

    I should say thanks to @Alaine for offering some suggestions. Too bad they didn't work out. Hopefully someone can come up with something.
     
  13. Megumin

    Megumin Guest

    i found new ways how to fix this,
    it should help i guess...
    1) disable your firewall
    2)update drivers
    3) install microsoft visual c++ NET Framework, DirectX, NVIDIA PhysX and etc...
    4) check free space on HDD
    5)install SwiftShader in folder with game
    6) are you using another symbols in user folder?
     
  14. Iris Blanche

    Iris Blanche Sealed Armament Forum Moderator

    Both logs are showing that starbound stopped normally. Are your nvidia driver settings for starbound are on default state? Have you altered your config (vsync and stuff)? Try removing the 3D-Vision driver if you don't need it. It's actual messing things up (had some weird problems with certain minecraft modpacks before removing it).

    I need you to ask to stop giving people advices which will affect their system security negative.

    ~ Iris ~
     
  15. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    Grabbed them from here. Tried both the 32 and 64 bit versions for both dx and gl. No change.

    Not quite sure what you mean. Debug symbols? I haven't done anything special here.

    Everything is in the defaults at this point. I don't have the 3D vision driver that I am aware of, but if I'm missing how to know for sure let me know :)

    As a note, yeah Starbound is "stopping normally". To be clear the program loads, but doesn't display anything correctly (see the screenshot above). It will sit like that forever as if it is at the main screen, until I exit it by hitting the normal windows X to close the game/window.
     
  16. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    Tried another thing with no improvement: completely disabled the integrated graphics card via Windows device manager. No impact, game still failed to really load with the same visual glitch. So either there's something just really broken whenever there are multiple graphics cards, or there's something really broken with my particular graphics card, which isn't even new or particularly strange/impressive. For the record my main graphics card is the Nvidia Geforce 750M (the machine is a laptop).
     
  17. Megumin

    Megumin Guest

    you tried to switch renders?
    your starbound is actually used [[Info] OpenGL version: '4.3.0 - Build 20.19.15.4549' vendor: 'Intel' renderer: 'Intel(R) HD Graphics 4600' shader: '4.30 - Build 20.19.15.4549'
    as log said, try to switch it to Nvidia then launch it again
     
  18. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    Hi Alain! Sorry for the slow reply. Which logs are you quoting from? (_working or the other one?) What I tried most recently was to physically disable the intel graphics card so that the computer would literally only think it had one graphics card. That didn't work. I can share that log if you would like.

    Can you describe how I would simply "Switch Renders"? I've been looking for a list of command line args or ways to reconfigure starbound but haven't come across anything descriptive.
     
  19. Megumin

    Megumin Guest

    please don't call me like that ( to prevent you from anything in further Alaine is name of my favorite game character)
    you are showing your low intelligence which can remember only 5 symbols of nickname
    the cards can be switched in Device manager
     
  20. JohnnyRandomWalker

    JohnnyRandomWalker Intergalactic Tourist

    1) Please don't be so unnecessarily mean when it was a simple mistype. I can edit it if you'd like, however you seem to have switched names so not sure what difference it makes now.
    2) Yes, switching the cards independently on/off via device manager is what I tried. No effect.
     

Share This Page