Announcement Multi Language Open Beta Available

Discussion in 'General Discussion' started by Katzeus, Feb 7, 2017.

Thread Status:
Not open for further replies.
  1. Python593

    Python593 Astral Cartographer

    Crash/Bug Report
    Language: Spanish
    Operating System: Windows 10
    Build Version: 1.2.20

    As you can see, some of the marked phrases or words are being hidden by some elements of the screen, maybe because they're not located correctly (for example, "Camisa" it's a little moved to the left).

    [​IMG]
     
    • Embos

      Embos Intergalactic Tourist

      Translation Feedback
      Language: Russian
      Operating System: Windows 7
      Build Version: 1.2.20


      I do not know English. But there are mistakes in translation (see screen).
      Мне стыдно, что такую хорошую игру переводят небрежно и халатно.
      Стоит взглянуть на эти скрины и становится сразу понятно что игру переводят даже не носители языка, это просто смешно...
      [​IMG]
      [​IMG]

      Пойду, положу на отдых...
       
        Last edited: Apr 9, 2017
      • ArleneFZ

        ArleneFZ Intergalactic Tourist

        你有发现哪些中文翻译变了吗?改变动物屋子的翻译还是没变
         
        • MikeNew

          MikeNew Master Chief

          Look like Google Translate. :eek:
           
          • Bardolvan

            Bardolvan Space Spelunker

            So when are Russian fixes coming? You said that you dont want our help because of "Legal issues", but you don't fix mistakes on your own. Why did you started this, if you can't finish it properly? What a shame.
             
            • Koihime Nakamura

              Koihime Nakamura Big Damn Hero

              Probably when the Russian translators get back to them.
               
              • paintingtheroses

                paintingtheroses Tentacle Wrangler

                Crash/Bug Report
                Language: English
                Operating System: Mac OSX
                Build Version: 1.2.20

                Using a gamepad and opening chests gives a sort of "phantom row" that the cursor finds if you click up from the topmost row in the chest grid. One gave me an incorrect status message (speed boost from pepper poppers, which I hadn't used that day) but most don't. This happens on all my chests. (The coffee status effect in the third screenshot is legitimate.)
                 

                  Attached Files:

                • Vernum

                  Vernum Void-Bound Voyager

                  Its not about the language but when using this beta, the tool hit location option doesn't seem to work correctly anymore with watering can. The red square always point in front of our character no matter where we move the mouse.
                   
                  • paintingtheroses

                    paintingtheroses Tentacle Wrangler

                    Realized that this row was the color picker, so it's selectable with the gamepad even when the color picker option is toggled off. Phantom status effects still occur. Real status effects often display incorrect times as well.
                     
                    • tccoxon

                      tccoxon Procedurally Generated Programmer Chucklefish

                      v1.2.24 changes (since v1.2.20)
                      • Fix snappy menu controls breaking the grange display menu
                      • Fixed a few minor issues with shop menus
                      • Fixed the player not getting the recipe for Cookies if they skip Evelyn's event
                      • Fixed a typo of the word 'pronounce' in the marriage event
                      • Increased stability of preference-saving code. This should fix infrequent crashes that require the player to delete startup_preferences
                      • Fixed a crash that can happen when a pig tries to spawn a truffle but there's no space for it
                      • Fixed a couple of rare crashes that could have occurred at any time during the game
                      For reference, here are the changes in the previous builds:
                       
                      • paintingtheroses

                        paintingtheroses Tentacle Wrangler

                        Since updating to the latest version of the beta, the game is unplayable and crashes on the launch screen. I uninstalled/reinstalled multiple times, and the game launches fine when the beta is turned off.
                         
                        • tccoxon

                          tccoxon Procedurally Generated Programmer Chucklefish

                          That's odd. Could you check if there are any logs in %appdata%\stardewvalley\errorlogs, and if so send them to me?
                           
                          • paintingtheroses

                            paintingtheroses Tentacle Wrangler

                            I'm on Mac and there isn't an errorlogs folder under user\.config\stardewvalley. Do they save somewhere else? Searches of my computer are coming up empty.
                             
                            • tccoxon

                              tccoxon Procedurally Generated Programmer Chucklefish

                              No, that's the correct directory. Have you tried running the game from outside Steam?

                              EDIT: I can reproduce this. I'm investigating and will hopefully soon have a fix!
                               
                                Last edited: Apr 19, 2017
                                paintingtheroses likes this.
                              • paintingtheroses

                                paintingtheroses Tentacle Wrangler

                                Thanks! Other people are reporting this too (1, 2, 3). Launching the game from outside Steam has the same problem.
                                 
                                • Pathoschild

                                  Pathoschild Existential Complex

                                  Many SMAPI users are reporting this crash in the game code when it's starting up:
                                  Code:
                                  System.Runtime.InteropServices.SEHException (0x80004005): External component has thrown an exception.
                                     at new[](UInt32 )
                                     at Microsoft.Xna.Framework.Audio.UnsafeNativeMethods.AllocateArrayAndReadFile(String filename, Void** ppData, UInt32* pdwBufferSize)
                                     at Microsoft.Xna.Framework.Audio.UnsafeNativeMethods.WaveBank.CreateHandle(UInt32 hEngine, String string, Int32 length, IntPtr& pCleanup)
                                     at Microsoft.Xna.Framework.Audio.WaveBank..ctor(AudioEngine audioEngine, String nonStreamingWaveBankFilename)
                                     at StardewValley.Game1.Initialize()
                                     at StardewModdingAPI.Framework.SGame.Initialize() in D:\source\_Stardew\SMAPI\src\StardewModdingAPI\Framework\SGame.cs:line 196
                                     at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
                                     at Microsoft.Xna.Framework.Game.Run()
                                     at StardewModdingAPI.Program.StartGame() in D:\source\_Stardew\SMAPI\src\StardewModdingAPI\Program.cs:line 274
                                  
                                  This happens in Game1::Initialize on this line:
                                  Code:
                                  Game1.waveBank = new WaveBank(Game1.audioEngine, Path.Combine(str, "XACT", "Wave Bank.xwb"));
                                  
                                  That error has been around for a long time (for both vanilla and modded players), but it's much more frequent in 1.2.24 beta.

                                  As far as I can tell, the WaveBank constructor has unmanaged code that's very sensitive to the app's resource usage before it gets initialised. If so, it might have suddenly worsened because Program.sdk.Initialize() now happens before the WaveBank is constructed (it was previously disabled in release builds).

                                  Maybe initialising the audio as early as possible would fix the problem?
                                   
                                    Last edited: Apr 19, 2017
                                  • Shiverwarp

                                    Shiverwarp Orbital Explorer

                                    Has anyone confirmed if the animal happiness decay for the farmer staying up late, is still a thing?
                                     
                                    • tccoxon

                                      tccoxon Procedurally Generated Programmer Chucklefish

                                      Thanks for the hints. I've swapped the SDK initialization and audio loading back to the original order. I was unable to reproduce these crashes in the first place, so I don't know for sure that it's fixed now. Hopefully things will go back to how they were before.

                                      v1.2.25 changes
                                      • Fixed broken Mac OS X app directory structure causing crashes on launch
                                      • Reverted the change to the ordering of Steam SDK initialization and audio loading, which is believed to have caused an increase in crashes on launch for some players
                                      For reference, here are the changes in the previous builds:
                                       
                                      • Yolanda_Qingxu

                                        Yolanda_Qingxu Star Wrangler

                                        测试版很多模组不能用所以最近都没在玩了,而且很多翻译错的太离谱了,完全没有专业性,看着让人失望。
                                        不过说起来上次我报错的买动物的提示语后来确实改了,是隔了好几次更新才改过来的。
                                         
                                        • Pathoschild

                                          Pathoschild Existential Complex

                                          Thanks! That seems to have fixed the increased occurrence.

                                          The error has always happened for a small subset of users (both vanilla and modded). Any chance you could move these three lines to the very top of Initialize (especially before base.Initialize() which runs LoadContent) to potentially fix it for everyone? The game seems to work fine with that change, based on some testing on our end.
                                          Code:
                                          Game1.audioEngine = new AudioEngine(Path.Combine(str, "XACT", "FarmerSounds.xgs"));
                                          Game1.waveBank = new WaveBank(Game1.audioEngine, Path.Combine(str, "XACT", "Wave Bank.xwb"));
                                          Game1.soundBank = new SoundBank(Game1.audioEngine, Path.Combine(str, "XACT", "Sound Bank.xsb"));
                                          
                                           
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page