1. Hey Guest! We've announced our new game Wargroove, check out the new forums!
    Dismiss Notice

Modding Help How to boot the game in steam with SMAPI?

Discussion in 'Mods' started by Kyler45, Mar 6, 2016.

  1. leonardord

    leonardord Space Hobo

    Well are you pressing yes or no on the user account control window? because you should be pressing yes
     
    • xChera

      xChera Void-Bound Voyager

      Alright, so the achievement I was going for was the one you get when you earn 50,000g. I earned 50,000g on SMAPI while not booting it through Steam... so do I still get that achievement? It seems like it's not. How do I fix that?
       
      • Jackoftrades222

        Jackoftrades222 Intergalactic Tourist

        I tried this and copied everything correctly, using the right click shift to copy the path, put it into steam and then it loads up fine, just no mods. The SMAPI window doesn't even show up. What am I doing wrong?
         
        • Ghostly Fox

          Ghostly Fox Existential Complex

          Not to be condescending, because I did it myself with a different game, but did you make sure that the letter at the starts of the pathway goes to your computer? It's J in the example, but for my newest computer, it's C. The one before it I would have had to have put "E:\Programfiles86\...etc"

          Basically saying that copying and pasting the link might not work depending on your computer and where you installed Steam on your computer.
           
          • Jackoftrades222

            Jackoftrades222 Intergalactic Tourist

            I went ahead and checked it again. It did double up on " on the front and end, yet still didn't load any mods with the start up.

            This is what I have entered into the box. %command% "C:\Program Files (x86)\Steam\SteamApps\common\Stardew Valley\StardewModdingAPI.exe" %command%

            Update

            After posting this message I saw what was wrong. For some reason %command% was added twice. After deleting it, things are work fine. Now screen shots without using fraps is possible. Thank you.
             
              wutangraiseu likes this.
            • Goldenecho

              Goldenecho Void-Bound Voyager

              hello! i just tried this,and my achievements are not getting saved to steam? i don't think i messed up anywhere,as i've followed everything here..
              any idea what the problem might be or how to fix it? im sort of an achievement hoarder,and i'd really like to get it working
               
              • Sameow

                Sameow Orbital Explorer

                So happy this post is here! Worked great for me. Thanks guys!
                 
                • José Neto

                  José Neto Space Hobo

                  Hey,i've done all the things that you guys have said,but the game won't start.What can I do ?(Sorry for my terrible english ;-; )
                   
                    Last edited: Jan 3, 2017
                  • Bringerlinger

                    Bringerlinger Orbital Explorer

                    Thanks very much! The full path in the start option was needed to launch without any issue. In the readme of the 1.7 SMAPI is written you have to just enter the StardewModding.exe %command% which lead to an error. But thx to you guys it works. :)
                     
                    • SetokaibaZA

                      SetokaibaZA Tentacle Wrangler

                      You guys rock. Thanks for this great tip. Was going to complain that it didn't work, but I took 1 final moment to double check everything and realised I typed like a twat. I had %commond% :rofl:
                       
                      • GiantPenguinGod

                        GiantPenguinGod Orbital Explorer

                        I think I got it working. Is a black box supposed to pop up and say things like loading mod?
                         
                        • Spmurkle

                          Spmurkle Space Hobo

                          Hello, Kyler45! If you want to have your Stardew Valley open in the StardewModdingAPI.exe, I have a solution.

                          1. Right click "Stardew Valley" in your library, and click "Properties".
                          [​IMG]

                          2. Under the tab "General" click "SET LAUNCH OPTIONS...".
                          [​IMG]

                          3. Type "StardewModdingAPI %command%" into the box, and click "OK".
                          [​IMG]

                          Make sure StardewModdingAPI.exe is inside of the "Steam\steamapps\common\Stardew Valley" folder! Otherwise, this will not work.
                           
                            HopeWasHere and Hammurabi like this.
                          • avengedluvee

                            avengedluvee Space Hobo

                            I've tried everything. Running as admin, not running as admin, launching through steam, and both the "StardewModdingAPI %command%" and "J:\SteamLibrary\steamapps\common\Stardew Valley\StardewModdingAPI.exe" %command%

                            Any solutions? Maybe it's a mod I have that is disabling it? No overlay shows and the achievements don't work. If anyone has any idea I'd very much appreciate it.
                            I'm running on Windows 10 if that helps.
                             
                            • DeLuuk

                              DeLuuk Void-Bound Voyager

                              Life saver!!!
                               
                              • Grendal27

                                Grendal27 Void-Bound Voyager

                                I did the %command% thing right, the game works, achievements count, hours count, but for some reason I can't to shift+tab to open the steam overlay, which is bearable but kinda annoying. I have the most recent version of SMAPI. Any way to fix it, or anyone else having that problem?
                                 

                                Share This Page