1. Hey Guest! Stardew Valley is now available on Xbox One and PlayStation 4!
    Dismiss Notice
  2. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Bug/Issue Game performance (Lags)

Discussion in 'Support' started by Cat_Fuzz, Sep 20, 2016.

  1. Cat_Fuzz

    Cat_Fuzz Astral Cartographer

    Hi guys,

    I'm still having issues with lag since 1.1. I tried 1.1.1 last night and I'm still getting pretty significant lag. I don't have an amazing computer but pre-1.1 my game was buttery smooth with a few exceptions.

    Now just exploring a planet grinds everything down to a very slow pace and monsters all try to do their best Trinity impression when jumping at me.

    Unless they've upgraded the specs for this game, this seems like a bug than a problem with my spec.
     
  2. Iris Blanche

    Iris Blanche Top Nep Forum Moderator

    Please provide your specs. Are you using any mods? If yes which ones?

    ~ Iris ~
     
  3. Cat_Fuzz

    Cat_Fuzz Astral Cartographer

    Again, by today's standards it's pretty ancient:

    2.66 GHz Core 2 Duo
    4Gb RAM
    Nvidia 9900M GC

    But even so, it was running great before 1.1. -1.0 worked fine. I also didn't see anything on needing a spec upgrade within the patch notes.
     
  4. Buttouchington

    Buttouchington Orbital Explorer

    Hey there can vouch for the same thing. The other day I only had minor amounts of lag in small extremely populated portions of the world. Now Anywhere that had furniture or chests in it creates massive frame drops.

    Specs are the following:
    Intel i7 Core i7-4500U @1.80 GHz 2.40GHz
    8GB ram
    Nvidia GeForce 745M

    I am running a few mods, such as Item frames and Hunger for casual, but They are all up to date and seem like they aren't causing the issue.
     
  5. Qndrez

    Qndrez Scruffy Nerf-Herder

    Same here, small amount of lag (just enough to be annoying) almost everywhere, but it was horrible when i went to a dark planet, i assume the weather effects were to blame there.

    Intel i7-3610QM
    16GB RAM
    Nvidia Geforce GTX 660M 2GB
    Windows 10

    EDIT: no mods.
    EDIT2: Snow planets affected. Anywhere there's weather, basically.
     
    Last edited: Sep 20, 2016
  6. Cat_Fuzz

    Cat_Fuzz Astral Cartographer

    I hope this can be solved in the next patch as it does make it less enjoyable to play - especially when pickups take a long time to work and monsters are easier to aim at as they move slowly.

    Also I'm re-quoting you @Iris Blanche as I didn't answer your question RE: mods - this is a clean install and as vanilla as it gets. Plus I'm Win 7.
     
  7. Cat_Fuzz

    Cat_Fuzz Astral Cartographer

    Apologies for the double post, but I've just ran the game at 32 bit with the lowest resolution and I'm having the same FPS rate as I would at my normal settings - surely as others with superior specs to mine are having a similar problem this is a legitimate issue, or at the very least, this game needs optimisation going forward.
     
    Last edited: Sep 21, 2016
  8. Captain Neckbeard

    Captain Neckbeard Space Hobo

    I'm having the same issue. Which is weird because... even after updating yesterday it was playable...its only unplayable today, the 20th. My FPS was down but still playable, now I'm thinking it might just be (After reading a lot of older posts) that its not optimized for my AMD processor and everything else.
     
  9. BigEaredKittens

    BigEaredKittens Subatomic Cosmonaut

    I also get FPS issue. Starbound stutters every second too, without end. This did not happen when my computer had crappier hardware.

    My old hardware struggled a bit while in densely populated towns. Tolerable.
    Now it grinds and stutters in such areas. stutters everywhere else too in game. Hardly playable. When warping from planet to planet it become very visable, the stuttering. YET, on the hardware I'm now using I can play games like Diablo 3, Oblivion, Saints Row 3, and Borderlands 2 with relatively smooth FPS.

    No fixes have worked for this issue, that I have found.

    Operating System
    Windows 7 Home Premium 64-bit SP1
    CPU
    AMD FX-6100 62 °C
    Zambezi 32nm Technology
    RAM
    16,0GB Dual-Channel DDR3 @ 664MHz (9-9-9-24)
    Motherboard
    Gigabyte 2AC8 (CPU 1) 45 °C
    Graphics
    DELL S2330MX (1920x1080@60Hz)
    1024MB ATI AMD Radeon HD 5670 (XFX Pine Group) 50 °C
    Storage
    1396GB Seagate ST1500DL003-9VT1 SCSI Disk Device (SATA) 29 °C
    Optical Drives
    DTSOFT Virtual CdRom Device
    hp DVD A DH16ABSH SCSI CdRom Device
    Audio
    IDT High Definition Audio CODEC
     
    Last edited: Sep 21, 2016
  10. Valiantic

    Valiantic Tentacle Wrangler

    To add to this thread from my own experience.

    My game was running butter smooth, zero issues with anything but I got a rig that outright devours this game (and it well should). This last patch on the 19th http://steamcommunity.com/games/211820/announcements/detail/974291008655879115 has turned the game from a butter-smooth experience to a slideshow whenever I'm on any ship.

    I've been using some ~40 mods from before 1.1.1 with no issues, checked them, updated the ones that had to/were updated (and tried the game without -any- mods, to no change.) Whatever you guys updated (and I'm no techie when it comes to that) is having serious negative effects.

    Windows 7 Home Premium, 64-bit
    Intel i7 990X Extreme Edition @3.47GHz
    16 Gigs RAM Dual Channel - DDR3.
    Nvidia Geforce GTX 690 (Two of them, in Quad SLI. Tried without, no change.)

    To put it into perspective. I can run GTA V almost maxed with a steady 60 FPS, I can run Shogun 2 again, 60 FPS. I can run Battlefield 4, maxed, 60 fps. This game, after the 1.1.1 update, drops my fps to 20 in the ship. The worlds are steady at 60 fps leading me to believe this is a coding hiccup/bug somewhere. My ship is currently at 4 crew members (so not even fully upgraded and/or fully decorated), the ship of my friend however, is fully upgraded and it drops my FPS to 14. The game becomes a slideshow.

    Fiddled with the Nvidia settings, disabled threaded optimization (long story short, all that pre-posting stuff.); No changes.

    Hopefully this can be pinned down and fixed quickly.
     
    Nothaniel likes this.
  11. BigEaredKittens

    BigEaredKittens Subatomic Cosmonaut

    Any response?
     
  12. BeckyRAT

    BeckyRAT Astral Cartographer

    Allow me to join in this; yes. I'm lagging like mad as well.

    My specs however, aren't weak. This tower is NOT old:

    CPU: AMD FX(tm)-8350 Eight-Core Processor (4200.28 MHz)
    Memory: 16357 MB
    OS Version: Microsoft Windows 7 SP1 64-bit (Build 7601)
    Graphics Card: GeForce GTX 960/PCIe/SSE2
    Windows Graphics Driver Version: 10.18.0013.6839
    OpenGL Version: 4.5.0 NVIDIA 368.39

    I do, however, have a ton of mods.

    I'll include my log file.

    It can be ran outside of Steam, but I have no way to play with my friends outside of steam. :/
     

    Attached Files:

  13. Cat_Fuzz

    Cat_Fuzz Astral Cartographer

    Any response?
     
  14. PaGooo

    PaGooo Space Spelunker

    I have the same problem with lag.My game runs at around 20-30 fps when i'm in a crouded area or when there is rain or snow.
    My PC specs:
    AMD FX 6100 (oc at 4.1 GHz)
    Sapphire Radeon R9 270 OC Dual-X 2GB
    2x4GB RAM 1600 MHz
    Windows 10 pro 64 bit
    I don't have any mods installed.

    I attached the log file.
     

    Attached Files:

  15. PaGooo

    PaGooo Space Spelunker

    So is anybody going to help us? I still don't know if my problem is that my pc specs are to low for this game or if the game is not running properly.
     
  16. Lord Aries Greyscale

    Lord Aries Greyscale Void-Bound Voyager

    well, as they still haven't updated the "system requirements" the problem isn't a matter of you not having enough grunt. Heck, yours beats mine on sheer performance.
     
  17. BigEaredKittens

    BigEaredKittens Subatomic Cosmonaut

    Hmmm. Skyrim not work before update drivers for GPU. Now skyrim also work and smoother than ever.

    This is definitely a coding problem with starbound. I shouldn't have to manually fix every game I buy and this one I have no idea how to fix.

    Any type of communication?
     
    Nothaniel likes this.
  18. bn880

    bn880 Poptop Tamer

    Same problem here, I end up playing in slow motion in MP Coop after a few minutes in a dungeon or in a busy house. Friend of mine in the game doesnt have the issue.

    i7-3610qm
    GTX 970m
    16GB ram
    850 pro SSD
    Win 10 64 bit
    Starbound 64 bit , low or hi rez, windowed or full screen.
     
  19. bn880

    bn880 Poptop Tamer

    I just found out that my Discrete GPU (GTX 970m ) is not being used, Starbound is using the Intel IGPU, hence the lag. I have set starbound.exe to use High Performance (Nvidia) GPU but no dice. :/

    Edit: Possible it's related to number of open/active Quests as well! Will check this out next 2 weeks.
     
    Last edited: Sep 26, 2016
  20. QuantumProjects

    QuantumProjects Space Spelunker

    If you're playing with Steam Overlay active, I suggest you disable it and test whether or not the lag stops. I usually have several performance issues in several games when Steam Overlay is active, and disabling it solved 99% of my performance problems.
     

Share This Page