1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Bug/Issue Game crashes when inventory item is manipulated

Discussion in 'Support' started by scaryokie, Jul 22, 2017.

  1. scaryokie

    scaryokie Seal Broken

    The game crashes every time my wife tries to manipulate any broadsword in her inventory or in a box. Sometimes it gives an Incoming Packet Exception error and kicks it to the main menu. Other times it crashes to desktop and gives an error message. This happens in both single player and multiplayer sessions.

    Windows 10 Home 64 bit; version 1703; build 15063.483
    No mods
    Full screen mode
    Error logs and a picture of the CTD error message are attached.
     

    Attached Files:

    PABL92 likes this.
  2. scaryokie

    scaryokie Seal Broken

    Small correction. The crash seems to only occur with manipulation of rare broadswords, but it happens every time.
     
  3. LoneTiger

    LoneTiger Orbital Explorer

    Having the same issue with an assault rifle, I picked it up at planet, all was fine until I clicked on it to move it to another slot game crashed.
    Same happens if I switch to single player, after login again into single or multiplayer rifle may be selected already by mouse so placing it on slot crashes game again.
    **IMAGE ATTACHED*** 072117starbound.png

    Extra info, after login in again as the rifle is in place in one slot I can use it, but if I switch between slots using mouse scroll it kicks me out again saying error about packet loss.
    **LOG ATTACHED**
    **CRASHLOG ATTACHED**
    The first log shows error when weapon is already selected and throws "Packet Error"
    The second log shows error when game crashes because I clicked on the gun in inventory.
    Windows 7 Pro 64 bit;
    No mods
    Window mode
     

    Attached Files:

    Last edited: Jul 22, 2017
    angryleek likes this.
  4. ScornfullOne

    ScornfullOne Space Hobo

    This is Identical to the issue I am having. It happened a few days ago with a spear, only way to get it working again was by deleting the spear. Issue popped up again with some clothing hoping I won't have to delete it this time lol
     
  5. DraikNova

    DraikNova Phantasmal Quasar

    Yeah, I had this same issue, on only one character, and only with rare broadswords. And only those I spawned in using admin commands. Other ones appeared to work fine.
     
  6. Cally94

    Cally94 Void-Bound Voyager

    Same exact problem as DraikNova, just started today with a brand new character... Not sure why it happened, but not sure how to remove the broadsword from my inventory either. Happens with all broadswords in my inventory, but I don't have any non-admin spawned swords to try out. All other items in inventory are fine, including other admin spawned items.

    I do not run any mods, and have been playing this game religiously for several weeks with no issues. Only this brand new character has had the issues. Also running with all drivers and steam up to date, on Win 10, 64-bit.

    Very strange...

    EDIT: I've done a bit more testing; I can confirm that no other characters have this problem with any item, spawned or not. Also, I have created a few more characters for testing, and none of them had this issue either. Maybe it's just bad luck? In the case of LoneTiger, deleting the item via editor or something (I don't actually know how to delete items without using the in-game bin...) would most likely fix the problem. But if in DraikNova or I's case, where our characters seem to have a problem with one weapon type (Mine also doesn't use energy when special att. with broadsword) this is a big problem... A messed up item here and there is annoying, but a character that can't use an entire set of items is very bad.

    At least it was only with one character though. Maybe a future update will clear up whatever is causing this, assuming that Chucklefish is aware of the problem anyways...

    EDIT 2: Nevermind, just started happening with another character that I've had for a while. Non-spawned common assault rifle, single-player. No idea what might be causing it. I guess some people have had success with deleting their universe and essentially restarting, but I really don't want to have to start over. But for those who don't mind, might be worth trying out if nothing else works.
     
    Last edited: Aug 13, 2017 at 4:08 AM

Share This Page