Modding Help Do's and Don'ts of reporting issues with SMAPI mods

Discussion in 'Mods' started by Entoarox, Oct 5, 2016.

  1. Lynthe Ytoo

    Lynthe Ytoo Space Hobo

    Hi! Can I get some help? I recently started to play with mods, no problem at all. Then I quit the game and after loading my save file it just shows a black screen. I uninstalled some mods and tried again, but I have the same issue. Here's the errorlog with no mods installed.
     

      Attached Files:

    • spacelion

      spacelion Space Hobo

      Ok so I dont know where to post this but here goes,

      I am trying to get SMAPI to work but it just crashes to desktop without loading if i boot it normally. I am using Smapi v 1.11 from april 30th, and my stardew is up to date I believe on 1.2.(opting out of betas) I am using steam and ubuntu with mono. When I run mono install.exe it installs everything supposedly but it then breaks my game until I uninstall it. I can get the game to boot further if i run stardewvalley.exe from the game folder with mono but it still crashes at the load game menu. I have tried to run the smapi.exe in the game folder but it boots to nothing. I also have no error log because it hasnt created a folder in .config/Stardew Valley/ ,only my saves are there. I believe my packages are upto date like mono sdl etc. although I dont think thats the problem as i get the installer to run just fine, I havent tried to add any mods to the game it is vanilla just with smapi and the trainermod it comes with. My install path is differnt than whats on the help page if that has any effect, (/home/user/.steam/steamapps/common/stardew valley. Any help is appreciated.
       
      • Ciriun

        Ciriun Void-Bound Voyager

        Sorry to have to post this since I'm sure it's got to be an easy fix I've overlooked, but after trying to add the CJB Item Spawner, I get the "black screen on loading a save" issue. I tried taking the mod out, and taking all of the SMAPI mods out, but it still happens. No mods at all in the appdata folder.
         

          Attached Files:

        • Entoarox

          Entoarox Parsec Taste Tester

          I am afraid this is a SDV 1.2 issue that SMAPI 1.12 causes to become more noticeable, downgrade to SMAPI 1.11 for now, SMAPI 1.13 should fix this.
           
          • Ciriun

            Ciriun Void-Bound Voyager

            Thanks for the quick reply. I don't know if it will be of any use to you to know, but I started a new save with all but the Item Spawner, and it played fine until I tried to zoom out a few times. I'll go get 1.11 now.
             
            • Entoarox

              Entoarox Parsec Taste Tester

              Yeah, CF did some strange things with SDV 1.2, lets hope they fix them soon.... because its getting annoying.... >_>
               
              • Karmylla

                Karmylla Subatomic Cosmonaut

                I'm getting a very strange crash! It started with when saving, the game would crash and, therefore not save, although there was no error log.
                Now, after copying my original save file and adding it to the save files, every time I click on either of the saves, the game goes back to the loading screen and I never get to play the game. This did add an error log, so that's good, at least to understand what I did wrong.
                I'm really sorry if this is a common error, or if it has already been solved. I searched on previous posts and saw nothing similar, but correct me if I'm wrong!
                 

                  Attached Files:

                • Entoarox

                  Entoarox Parsec Taste Tester

                  Please confirm that this issue happens with SMAPI 1.10, apparently some weirdness is going on with recent SMAPI versions, so I need it confirmed that this is not also caused by that.
                   
                  • Karmylla

                    Karmylla Subatomic Cosmonaut

                    @Entoarox I was actually using 1.12 - that's my bad, sorry - but I downloaded 1.10 again and now I can't load any of the saves, the game changes to full screen and I go back to the loading screen. Both 1.10 and 1.12 give the same error log:
                    Code:
                    [14:56:19 ERROR Console.Out] System.ObjectDisposedException: Cannot access a disposed object.
                    Object name: 'Entoarox.Framework.SmartContentManager'.
                       at Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
                       at StardewValley.LocalizedContentManager.Load[T](String assetName)
                       at Entoarox.Framework.SmartContentManager.Load[T](String assetName) in d:\documents\visual studio 2015\Projects\StardewMods\Framework\Internal\SmartContentManager.cs:line 42
                       at StardewValley.Game1.loadForNewGame(Boolean loadedGame)
                       at StardewValley.SaveGame.<>c.<getLoadEnumerator>b__51_1()
                       at System.Threading.Tasks.Task.InnerInvoke()
                       at System.Threading.Tasks.Task.Execute()
                     

                      Attached Files:

                    • Entoarox

                      Entoarox Parsec Taste Tester

                      great... guess I need to figure out what CF messed up now >_<
                       
                        Karmylla likes this.
                      • Cololita

                        Cololita Void-Bound Voyager

                        Unhandled Exception: System.MissingFieldException: Field not found: 'StardewValley.Game1.version'.
                        at StardewModdingAPI.Program.Main()
                        Hello Recently updated the game and have the latest version of SMAPI, above is all that shows and not sure why the game wont even open. I then removed all my mods and still nothing. please help...
                         
                        • Entoarox

                          Entoarox Parsec Taste Tester

                          This is saying you do *not* have the latest version of SDV, you need 1.2.30
                           
                          • BigDCal

                            BigDCal Space Hobo

                            So i just tried to install smapi 1.15 im pretty sure and so when the stardew valley file is open and i try to run the modded stardew launcher it says it cant find stardew valley but when i copied it to the desktop it runs but crashes immediately
                             
                            • Entoarox

                              Entoarox Parsec Taste Tester

                               
                              • fatar

                                fatar Space Hobo

                                What happens: Game crashes almost randomly, most likely when traveling around

                                I can see in the crash logs that the directory the modding api is looking at (D : source) is completely wrong since my stardew is installed on my C harddrive, is there any way to easily fix this?
                                Thanks in advance for the help, this happens with the Entoarox Framework+Shop Expander+Even more crops mods
                                 

                                  Attached Files:

                                • FieryChaos

                                  FieryChaos Big Damn Hero

                                  Your objectinformation.xnb file is outdated (from EMCM). Download this updated version for use with SDV 1.2+. The game is likely crashing when hovering over an item (because of the outdated objectinformation.xnb file missing a field that was added in the SDV 1.2 update). Don't worry about the D drive thing, that is just where the source is located on @Pathoschild computer.
                                   
                                  • fatar

                                    fatar Space Hobo

                                    Thanks FieryChaos, that fixed it! Have a good day
                                     

                                    Share This Page