1. If you're looking for help-related things (for example, the key rebinding tutorial), please check the FAQ and Q&A forum! A lot of the stickies from this forum have been moved there to clean up space.

[GUIDE] Multiplayer w/ Hamachi

Discussion in 'General Discussion' started by Velcrohead, Dec 4, 2013.

[GUIDE] Multiplayer w/ Hamachi

Discussion in 'General Discussion' started by Velcrohead, Dec 4, 2013.

  1. Velcrohead

    Velcrohead Void-Bound Voyager

    Ok guys, quick guide so I can go back to playing.

    If you're having trouble getting online with your friends, do this.

    1) Google hamachi, download it (unmanaged version is fine)
    2) Whoever's host will also need to download it
    3) Install
    4) Get host to 'create new network', and to give you the exact Name and password of the group
    5) Join the hosts hamachi group
    6) Go to Multiplayer in Starbound, and type in the 'direct Tunnel' address that's underneath the hosts name, in Hamachi.

    No pictures & not much detail because I wanna go play, but it'll do.

    ALSO - For people who are having issues with the game, go to Program Files(x86) / Steam / SteampApps / Common / Starbound / Win32 --- RIGHT CLICK STARBOUND.EXE AND RUN AS ADMINISTRATOR. HELPS.

    ALSO some solid advice for those having issues :
      Last edited: Dec 4, 2013
    • se05239

      se05239 Industrial Terraformer

      Good to know.
      • Hazmat2142

        Hazmat2142 Void-Bound Voyager

        If it worked. Been trying to connect since it started still haven't gotten into a multiplayer server
        • garbud

          garbud Orbital Explorer

          sweet thank you cant wait to try this out when i get home.
          • Flatland

            Flatland Space Hobo

            Hey thanks for this.
            • Velcrohead

              Velcrohead Void-Bound Voyager

              Get the host to use hamachi / set up your own server & utilise Hamachi!
              • Amadurr

                Amadurr Space Hobo

                It seems as if I can connect to my own server but my friend can not. We have all our FW's and such deactivated so it shouldnt be an issue as far as i'm concerned. We are also using the correct hamachi IP's.

                Does anyone else know what the issue might be?
                • Katsaurs

                  Katsaurs Void-Bound Voyager

                  I managed to get it working with this guide so props to you.

                  For those having issues, make sure the person who's hosting is running the starbound_server.exe first before anyone tries to connect using the Hamachi address of your network, that seemed to be the issue behind our connection woes if it helps :)
                    DeeVicarious likes this.
                  • Velcrohead

                    Velcrohead Void-Bound Voyager

                    That's a really good point, I'll add it into the main post!
                    • Monster Tamer Billy

                      Monster Tamer Billy Orbital Explorer

                      I've some personal issues with Hamachii (myself, not in the game), but I'll try testing it with Evolve.
                      • Incendie

                        Incendie Space Spelunker

                        Does the host connect to his own Hamachi IP?
                        • Ordel

                          Ordel Aquatic Astronaut

                          Been messing around with hamachi too.
                          I've not gotten it to work yet, but here are a few tips for those that don't know them:
                          FW off, helps alot.
                          Play around with your IP's. There's like 3 viable ones that I, myself, can use to get onto the server, yet none work for my friend. Stumped here.
                          Ip websites are your friend. What'smyip and ipchicken are the 2 i'd use most, along with cmd.exe.

                          EDIT: If you're using hamachi, use the hamachi ip but also run the server cmd.exe (as Katsaurs said)
                          That includes you aswell, use your own hamachi ip.
                            Last edited: Dec 5, 2013
                          • DonkeyFlap

                            DonkeyFlap Master Chief

                            im having trouble with mine, every time i connect it says somthing about a port not beeing open, but im using hamachi
                            • Thonghuff

                              Thonghuff Space Hobo

                              some on pls help i can't connect with my buddy and we did every thing yall said
                              • FreeSoul

                                FreeSoul Master Chief

                                I tried it all buddy, seriously we just tried Terraria with Hamachi and it's working just fine... then we tried SB again, not working, the problem is not on our side...
                                  furag0n likes this.
                                • Angryhatter

                                  Angryhatter Intergalactic Tourist

                                  Well me and my friend have just been trying to get this working through Hamachi for the better part of an hour and no luck. We have checked that ports are not being blocked and even created a rule to allow the port the server wants to use in and out on the off chance it was being blocked (highly unlikely given the settings but there you go). We then created a new Hamachi group and have both attempted to run as host with no luck. It allows us to play in our own servers but no one else can join. They just get a server error.
                                  The exact same set up works for other games, such as Contagion, so I really doubt the issue is here, it's just unusual that some people seem to be able to get on and not others.
                                    Mike the Miner, FreeSoul and furag0n like this.
                                  • kevandcass

                                    kevandcass Space Spelunker

                                    One thing you may have to do is when you start Hamachi for the first time, it pops up a new network dialog and you have to categorize it... home, work or public. Make sure in the Firewall settings you have Starbound enabled for whatever category to setup the "new network" as. Mine came up as "Network 2". Sometimes you have to restart if you change any Firewall settings.
                                      Takahiro86 likes this.
                                    • Velcrohead

                                      Velcrohead Void-Bound Voyager

                                      If it makes you guys feel any better, it's not working for me either now,
                                      • NitrousNetworks

                                        NitrousNetworks Intergalactic Tourist

                                      • se05239

                                        se05239 Industrial Terraformer

                                        I rather go through a hassle and get it for free, so sorry.

                                        Share This Page